CVE-2021-30164
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes...
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
- Record
CVE-2021-30164- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
- Record
CVE-2021-30164- Updated
- 2026-11-02
EUVDEUVD-2021-17100 No score
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
- Record
EUVD-2021-17100- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8c7v-26g9-8vwr No score
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes...
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
- Record
GHSA-8c7v-26g9-8vwr- Updated
- 2026-11-02
OSV
9.8
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
- Record
CVE-2021-30164- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-30164
9.8
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
- Record
DEBIAN-CVE-2021-30164- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-30164
9.8
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
- Record
UBUNTU-CVE-2021-30164- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBIT-redmine-2021-30164 No score
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
- Record
BIT-redmine-2021-30164- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
redmineBitnami |
before 4.0.8, 4.1.0 up to 4.1.2 | 4.0.84.1.2 |
redmineDebian:12 |
before 5.0.0-1 | 5.0.0-1 |
redmineDebian:13 |
before 5.0.0-1 | 5.0.0-1 |
redmineDebian:14 |
before 5.0.0-1 | 5.0.0-1 |
redmineDebian:9 From an advisory covering 10 CVEs |
before 3.3.1-4+deb9u4, plus listed versions 3.3.1-43.3.1-4+deb9u13.3.1-4+deb9u23.3.1-4+deb9u3 |
3.3.1-4+deb9u4 |
redmineUbuntu:16.04:LTS |
All versions, plus listed versions 3.0~20140825-83.2.0-13.2.0-33.2.1-13.2.1-23.2.1-2ubuntu0.2 |
None known |
redmineUbuntu:18.04:LTS |
All versions, plus listed versions 3.3.1-43.4.2-13.4.4-13.4.4-1ubuntu0.1 |
None known |
redmineUbuntu:20.04:LTS |
All versions, plus listed versions 4.0.4-14.0.4-34.0.6-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-30164 is a critical vulnerability (CVSS 9.8) in Redmine, published April 6, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.32%, the 70th percentile. Fixed in redmine 4.0.8.
References
redmine.org/projects/redmine/wiki/Security_Advisories
lists.debian.org/debian-lts-announce/2021/05/msg00013.html
nvd.nist.gov/vuln/detail/CVE-2021-30164
github.com/advisories/GHSA-8c7v-26g9-8vwr
security-tracker.debian.org/tracker/CVE-2021-30164
ubuntu.com/security/CVE-2021-30164
cve.org/CVERecord?id=CVE-2021-30164