CVE-2021-31164
Apache Unomi log injection
Apache Unomi prior to version 1.5.5 allows CRLF log injection because of the lack of escaping in the log statements.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
Apache Unomi prior to version 1.5.5 allows CRLF log injection because of the lack of escaping in the log statements.
- Record
CVE-2021-31164- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-93, CWE-74
- Updated
- 2026-11-02
CVE List No score
Apache Unomi log injection
Apache Unomi prior to version 1.5.5 allows CRLF log injection because of the lack of escaping in the log statements.
- Record
CVE-2021-31164- Weakness
- CWE-93
- Updated
- 2026-11-02
EUVDEUVD-2021-1399 No score
Apache Unomi prior to version 1.5.5 allows CRLF log injection because of the lack of escaping in the log statements.
- Record
EUVD-2021-1399- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rm7f-mpcj-w4f6
7.5
Command injection in Apache Unomi
Apache Unomi prior to version 1.5.5 allows CRLF log injection because of the lack of escaping in the log statements.
- Record
GHSA-rm7f-mpcj-w4f6- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-74
- Updated
- 2026-11-02
OSV
7.5
Apache Unomi prior to version 1.5.5 allows CRLF log injection because of the lack of escaping in the log statements.
- Record
CVE-2021-31164- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-rm7f-mpcj-w4f6
7.5
Command injection in Apache Unomi
Apache Unomi prior to version 1.5.5 allows CRLF log injection because of the lack of escaping in the log statements.
- Record
GHSA-rm7f-mpcj-w4f6- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-74
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.unomi:unomiMaven |
before 1.5.5 | 1.5.5 |
org.apache.unomi:unomiMaven |
before 1.5.5, plus listed versions 1.0.0-incubating1.1.0-incubating1.2.0-incubating1.3.0-incubating1.5.0 Show 4 moreShow less1.5.11.5.21.5.31.5.4 |
1.5.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-31164 is a high vulnerability (CVSS 7.5) in Apache Unomi, published May 4, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.28%, the 83rd percentile. Fixed in org.apache.unomi:unomi 1.5.5.