CVE-2021-31863
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x...
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
- Record
CVE-2021-31863- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
- Record
CVE-2021-31863- Updated
- 2026-11-02
EUVDEUVD-2021-18738 No score
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
- Record
EUVD-2021-18738- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8hvw-4p82-cf4x No score
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x...
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
- Record
GHSA-8hvw-4p82-cf4x- Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.5
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
- Record
CVE-2021-31863- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-31863
7.5
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
- Record
DEBIAN-CVE-2021-31863- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-31863
7.5
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
- Record
UBUNTU-CVE-2021-31863- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVBIT-redmine-2021-31863 No score
Insufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
- Record
BIT-redmine-2021-31863- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
redmineBitnami |
before 4.0.9, 4.1.0 up to 4.1.3, 4.2.0 up to 4.2.1 | 4.0.94.1.34.2.1 |
redmineDebian:12 |
before 5.0.0-1 | 5.0.0-1 |
redmineDebian:13 |
before 5.0.0-1 | 5.0.0-1 |
redmineDebian:14 |
before 5.0.0-1 | 5.0.0-1 |
redmineDebian:9 From an advisory covering 10 CVEs |
before 3.3.1-4+deb9u4, plus listed versions 3.3.1-43.3.1-4+deb9u13.3.1-4+deb9u23.3.1-4+deb9u3 |
3.3.1-4+deb9u4 |
redmineUbuntu:16.04:LTS |
All versions, plus listed versions 3.0~20140825-83.2.0-13.2.0-33.2.1-13.2.1-23.2.1-2ubuntu0.2 |
None known |
redmineUbuntu:18.04:LTS |
All versions, plus listed versions 3.3.1-43.4.2-13.4.4-13.4.4-1ubuntu0.1 |
None known |
redmineUbuntu:20.04:LTS |
All versions, plus listed versions 4.0.4-14.0.4-34.0.6-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-31863 is a high vulnerability (CVSS 7.5) in Redmine, published April 28, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.74%, the 77th percentile. Fixed in redmine 4.0.9.
References
redmine.org/projects/redmine/wiki/Security_Advisories
redmine.org/news/131
lists.debian.org/debian-lts-announce/2021/05/msg00013.html
nvd.nist.gov/vuln/detail/CVE-2021-31863
github.com/advisories/GHSA-8hvw-4p82-cf4x
security-tracker.debian.org/tracker/CVE-2021-31863
ubuntu.com/security/CVE-2021-31863
cve.org/CVERecord?id=CVE-2021-31863