CVE-2021-31998
inn: %post calls user owned file allowing local privilege escalation to root
A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise Server 11-SP3; openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2 allows local attackers to escalate their privileges from the news user to root. This issue affects: SUSE Linux Enterprise Server 11-SP3 inn version inn-2.4.2-170.21.3.1 and prior versions. openSUSE Backports SLE-15-SP2 inn versions prior to 2.6.2. openSUSE Leap 15.2 inn versions prior to 2.6.2.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.8
inn: %post calls user owned file allowing local privilege escalation to root
A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise Server 11-SP3; openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2 allows local attackers to escalate their privileges from the news user to root. This issue affects: SUSE Linux Enterprise Server 11-SP3 inn version inn-2.4.2-170.21.3.1 and prior versions. openSUSE Backports SLE-15-SP2 inn versions prior to 2.6.2. openSUSE Leap 15.2 inn versions prior to 2.6.2.
- Record
CVE-2021-31998- CVSS 3.1
- 6.8 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - Weakness
- CWE-276
- Updated
- 2026-11-02
EUVDEUVD-2021-18869
6.8
A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise Server 11-SP3; openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2 allows local attackers to escalate their privileges from the news user to root. This issue affects: SUSE Linux Enterprise Server 11-SP3 inn version inn-2.4.2-170.21.3.1 and prior versions. openSUSE Backports SLE-15-SP2 inn versions prior to 2.6.2. openSUSE Leap 15.2 inn versions prior to 2.6.2.
- Record
EUVD-2021-18869- CVSS 3.1
- 6.8 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rqpg-j7j6-g58g No score
A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise...
A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise Server 11-SP3; openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2 allows local attackers to escalate their privileges from the news user to root. This issue affects: SUSE Linux Enterprise Server 11-SP3 inn version inn-2.4.2-170.21.3.1 and prior versions. openSUSE Backports SLE-15-SP2 inn versions prior to 2.6.2. openSUSE Leap 15.2 inn versions prior to 2.6.2.
- Record
GHSA-rqpg-j7j6-g58g- Weakness
- CWE-276
- Updated
- 2026-11-02
NVD
6.8
A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise Server 11-SP3; openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2 allows local attackers to escalate their privileges from the news user to root. This issue affects: SUSE Linux Enterprise Server 11-SP3 inn version inn-2.4.2-170.21.3.1 and prior versions. openSUSE Backports SLE-15-SP2 inn versions prior to 2.6.2. openSUSE Leap 15.2 inn versions prior to 2.6.2.
- Record
CVE-2021-31998- CVSS 3.1
- 6.8 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.2 High
AV:L/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-276
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-31998
6.8
A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise Server 11-SP3; openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2 allows local attackers to escalate their privileges from the news user to root. This issue affects: SUSE Linux Enterprise Server 11-SP3 inn version inn-2.4.2-170.21.3.1 and prior versions. openSUSE Backports SLE-15-SP2 inn versions prior to 2.6.2. openSUSE Leap 15.2 inn versions prior to 2.6.2.
- Record
UBUNTU-CVE-2021-31998- CVSS 3.1
- 6.8 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N - CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2021:0830-1 No score
Security update for inn
This update for inn fixes the following issues:
- CVE-2021-31998: change user to news before calling innupgrade, which could have allow local privilege escalation. [boo#1182321]
- Record
openSUSE-SU-2021:0830-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2021:0845-1 No score
Security update for inn
This update for inn fixes the following issues:
- CVE-2021-31998: change user to news before calling innupgrade, which could have allow local privilege escalation. [boo#1182321]
This update was imported from the openSUSE:Leap:15.2:Update update project.
- Record
openSUSE-SU-2021:0845-1- Updated
- 2026-11-02
OSVSUSE-SU-2021:14750-1 No score
Security update for inn
This update for inn fixes the following issues:
- CVE-2021-31998: Fixed locale privialge escalation during the update of inn (bsc#1182321).
- Record
SUSE-SU-2021:14750-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
innSUSE:Linux Enterprise Point of Sale 11 SP3 |
before 2.4.2-170.21.3.6.1 | 2.4.2-170.21.3.6.1 |
innSUSE:Linux Enterprise Server 11 SP4-LTSS |
before 2.4.2-170.21.3.6.1 | 2.4.2-170.21.3.6.1 |
inn2Ubuntu:16.04:LTS |
All versions, plus listed versions 2.5.4-32.6.0-12.6.0-2 |
None known |
inn2Ubuntu:18.04:LTS |
All versions, plus listed versions 2.6.1-2build12.6.1-32.6.1-42.6.1-4build1 |
None known |
inn2Ubuntu:20.04:LTS |
All versions, plus listed versions 2.6.3-2build12.6.3-2build22.6.3-3 |
None known |
inn2Ubuntu:22.04:LTS |
All versions, plus listed versions 2.6.4-2build12.6.4-2build22.6.4-2build32.6.4-2build4 |
None known |
inn2Ubuntu:24.04:LTS |
All versions, plus listed versions 2.7.2~20230806-12.7.2~20230917-12.7.2~20231223-12.7.2~20240120-1ubuntu12.7.2~20240212-12.7.2~20240212-1build22.7.2~20240212-1build3 |
None known |
inn2Ubuntu:25.10 |
All versions, plus listed versions 2.7.3~20250201-12.7.3~rc1-12.7.3-1 |
None known |
inn2Ubuntu:26.10 |
All versions, plus listed versions 2.7.4~20250809-1build12.7.4~20260419-12.7.4-12.7.4-1build12.7.4-1build2 |
None known |
inn2Ubuntu:26.04:LTS |
All versions, plus listed versions 2.7.3-12.7.4~20250809-12.7.4~20250809-1build1 |
None known |
innopenSUSE:Leap 15.2 |
before 2.6.2-lp152.2.6.1 | 2.6.2-lp152.2.6.1 |
innSUSE:Package Hub 15 SP2 |
before 2.6.2-bp152.2.8.1 | 2.6.2-bp152.2.8.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-31998 is a medium vulnerability (CVSS 6.8) in Opensuse Inn, published June 3, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.32%, the 24th percentile. Fixed in inn 2.4.2-170.21.3.6.1.