Every CVE Search/ Get API key

CVE-2021-32062

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and...

5.3 MediumFix available

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 does not properly enforce the MS_MAP_NO_PATH and MS_MAP_PATTERN restrictions that are intended to control the locations from which a mapfile may be loaded (with MapServer CGI).

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

1.51%Up 0.5 points since May 7, 2021
90%50%10%1%

What each source reports

NVD Score used 5.3

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 does not properly enforce the MS_MAP_NO_PATH and MS_MAP_PATTERN restrictions that are intended to control the locations from which a mapfile may be loaded (with MapServer CGI).

Record
CVE-2021-32062
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 does not properly enforce the MS_MAP_NO_PATH and MS_MAP_PATTERN restrictions that are intended to control the locations from which a mapfile may be loaded (with MapServer CGI).

Record
CVE-2021-32062
Updated
2026-11-02
EUVDEUVD-2021-18924 No score

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 does not properly enforce the MS_MAP_NO_PATH and MS_MAP_PATTERN restrictions that are intended to control the locations from which a mapfile may be loaded (with MapServer CGI).

Record
EUVD-2021-18924
Updated
2026-11-03
GitHub AdvisoriesGHSA-2cph-rvmj-cx7r 5.3

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and...

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 does not properly enforce the MS_MAP_NO_PATH and MS_MAP_PATTERN restrictions that are intended to control the locations from which a mapfile may be loaded (with MapServer CGI).

Record
GHSA-2cph-rvmj-cx7r
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
OSV 5.3

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 does not properly enforce the MS_MAP_NO_PATH and MS_MAP_PATTERN restrictions that are intended to control the locations from which a mapfile may be loaded (with MapServer CGI).

Record
CVE-2021-32062
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2021-32062 5.3

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 does not properly enforce the MS_MAP_NO_PATH and MS_MAP_PATTERN restrictions that are intended to control the locations from which a mapfile may be loaded (with MapServer CGI).

Record
DEBIAN-CVE-2021-32062
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2021-32062 5.3

MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 does not properly enforce the MS_MAP_NO_PATH and MS_MAP_PATTERN restrictions that are intended to control the locations from which a mapfile may be loaded (with MapServer CGI).

Record
UBUNTU-CVE-2021-32062
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2024:11037-1 No score

libjavamapscript-7.6.3-1.2 on GA media

These are all security issues fixed in the libjavamapscript-7.6.3-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11037-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mapserver
Debian:12
before 7.6.2-2
7.6.2-2
mapserver
Debian:13
before 7.6.2-2
7.6.2-2
mapserver
Debian:14
before 7.6.2-2
7.6.2-2
mapserver
Debian:11
From an advisory covering 2 CVEs
before 7.6.2-1+deb11u1, plus listed versions
7.6.2-1
7.6.2-1+deb11u1
mapserver
Ubuntu:16.04:LTS
All versions, plus listed versions
7.0.0-4build17.0.0-5ubuntu17.0.0-77.0.0-87.0.0-8build1
Show 5 moreShow less
7.0.0-97.0.0-9ubuntu17.0.0-9ubuntu27.0.0-9ubuntu37.0.0-9ubuntu3.1
None known
mapserver
Ubuntu:18.04:LTS
All versions, plus listed versions
7.0.6-2build17.0.7-17.0.7-1build17.0.7-1build2
None known
mapserver
Ubuntu:20.04:LTS
All versions, plus listed versions
7.4.1-1build17.4.1-1build37.4.2-17.4.2-1build17.4.3-17.4.3-1build27.4.3-27.4.3-2build1
None known
mapserver
Ubuntu:22.04:LTS
All versions, plus listed versions
7.6.3-1~exp1ubuntu17.6.4-27.6.4-2build2
None known
mapserver
Ubuntu:24.04:LTS
All versions, plus listed versions
8.0.1-2build18.0.1-2build28.0.1-2build38.0.1-2build58.0.1-4ubuntu18.0.1-4ubuntu2
None known
mapserver
Ubuntu:25.10
All versions, plus listed versions
8.4.0-1build18.4.0-48.4.0-4build1
None known
mapserver
Ubuntu:26.10
All versions, plus listed versions
8.6.0-1build18.6.4-18.6.5-18.6.5-1build1
None known
mapserver
Ubuntu:26.04:LTS
All versions, plus listed versions
8.4.0-4build18.4.1-18.4.1-1build18.4.1-28.4.1-2build18.6.0-18.6.0-1build1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-32062 is a medium vulnerability (CVSS 5.3) in Osgeo Mapserver, published May 5, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.51%, the 74th percentile. Fixed in mapserver 7.6.2-2.

References

Show 15 moreShow less
MoveEnter Open