Every CVE Search/ Get API key

CVE-2021-32297

LIEF heap-buffer-overflow

8.8 HighFix available

CVE-2021-32297 is a high vulnerability (CVSS 8.8) in Lief-project Lief, published September 20, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.56%, the 75th percentile. Fixed in lief 0.11.0.

An issue was discovered in LIEF through 0.11.4. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.56%Up 0.8 points since Sep 21, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

An issue was discovered in LIEF through 0.11.4. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.

Record
CVE-2021-32297
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

An issue was discovered in LIEF through 0.11.4. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.

Record
CVE-2021-32297
Updated
2026-11-02
EUVDEUVD-2021-0109 No score

An issue was discovered in LIEF through 0.11.4. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.

Record
EUVD-2021-0109
Updated
2026-11-03
GitHub AdvisoriesGHSA-22x7-vwh9-5w4g 8.6

LIEF heap-buffer-overflow

An issue was discovered in LIEF prior to version 0.11.0. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.

Record
GHSA-22x7-vwh9-5w4g
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 8.8

An issue was discovered in LIEF through 0.11.4. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.

Record
CVE-2021-32297
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-22x7-vwh9-5w4g 8.6

LIEF heap-buffer-overflow

An issue was discovered in LIEF prior to version 0.11.0. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.

Record
GHSA-22x7-vwh9-5w4g
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSVUBUNTU-CVE-2021-32297 8.8

An issue was discovered in LIEF through 0.11.4. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.

Record
UBUNTU-CVE-2021-32297
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVPYSEC-2021-324 No score

An issue was discovered in LIEF through 0.11.4. A heap-buffer-overflow exists in the function main located in pe_reader.c. It allows an attacker to cause code Execution.

Record
PYSEC-2021-324
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lief
PyPI
before 0.11.0
0.11.0
lief
PyPI
before 0.11.0, plus listed versions
0.10.00.10.10.8.00.8.10.8.20.8.30.9.0
0.11.0
lief
PyPI
before 0.11.5, plus listed versions
0.10.00.10.10.11.00.11.10.11.2
Show 7 moreShow less
0.11.30.11.40.8.00.8.10.8.20.8.30.9.0
0.11.5
lief
Ubuntu:20.04:LTS
All versions, plus listed versions
0.9.0-1build10.9.0-1build2
None known
lief
Ubuntu:22.04:LTS
All versions, plus listed versions
0.9.0-1build20.9.0-1build3
None known

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open