CVE-2021-32561
OctoPrint API Error Messages vulnerable to XSS
OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.
- Record
CVE-2021-32561- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.
- Record
CVE-2021-32561- Updated
- 2026-11-02
EUVDEUVD-2021-0155 No score
OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.
- Record
EUVD-2021-0155- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vcx4-fpmp-mvv6
5.3
OctoPrint API Error Messages vulnerable to XSS
OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.
- Record
GHSA-vcx4-fpmp-mvv6- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.
- Record
CVE-2021-32561- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-vcx4-fpmp-mvv6
5.3
OctoPrint API Error Messages vulnerable to XSS
OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.
- Record
GHSA-vcx4-fpmp-mvv6- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVPYSEC-2021-30 No score
OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.
- Record
PYSEC-2021-30- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
octoprintPyPI |
before 1.6.0 | 1.6.0 |
octoprintPyPI |
before 1.6.0, plus listed versions 1.3.111.3.121.3.12rc11.3.12rc31.4.0 Show 22 moreShow less1.4.0rc11.4.0rc21.4.0rc31.4.0rc41.4.0rc51.4.0rc61.4.11.4.1rc11.4.1rc21.4.1rc31.4.1rc41.4.21.5.01.5.0rc11.5.0rc21.5.0rc31.5.11.5.21.5.31.6.0rc11.6.0rc21.6.0rc3 |
1.6.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-32561 is a medium vulnerability (CVSS 6.1) in Octoprint, published May 11, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 67th percentile. Fixed in octoprint 1.6.0.
References
octoprint.org/blog/2021/04/27/new-release-1.6.0
github.com/OctoPrint/OctoPrint/releases/tag/1.6.0
brzozowski.io/web-applications/2021/05/11/the-insecure-story-of-octoprint.html
nvd.nist.gov/vuln/detail/CVE-2021-32561
github.com/pypa/advisory-database/tree/main/vulns/octoprint/PYSEC-2021-30.yaml
brzozowski.io
github.com/advisories/GHSA-vcx4-fpmp-mvv6
github.com/OctoPrint/OctoPrint