Every CVE Search/ Get API key

CVE-2021-32667

Cross-Site Scripting in Page Preview

6.4 MediumFix available

TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When Page TSconfig settings are not properly encoded, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.60%Down 0.1 points since Jul 21, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.4

Cross-Site Scripting in Page Preview

TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When Page TSconfig settings are not properly encoded, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this issue.

Record
CVE-2021-32667
CVSS 3.1
6.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2021-1452 6.4

TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When Page TSconfig settings are not properly encoded, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this issue.

Record
EUVD-2021-1452
CVSS 3.1
6.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-8mq9-fqv8-59wf 6.4

Cross-Site Scripting in Page Preview

Meta

  • CVSS: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC (5.0)

Problem

Failing to properly encode Page TSconfig settings, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability.

Solution

Update to TYPO3 versions 9.5.28, 10.4.18, 11.3.1 that fix the problem described.

Credits

Thanks to TYPO3 core merger Oliver Bartsch who reported and fixed the issue.

References

Record
GHSA-8mq9-fqv8-59wf
CVSS 3.1
6.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 6.4

TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When Page TSconfig settings are not properly encoded, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this issue.

Record
CVE-2021-32667
CVSS 3.1
6.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When Page TSconfig settings are not properly encoded, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this issue.

Record
CVE-2021-32667
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-8mq9-fqv8-59wf 6.4

Cross-Site Scripting in Page Preview

Meta

  • CVSS: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC (5.0)

Problem

Failing to properly encode Page TSconfig settings, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability.

Solution

Update to TYPO3 versions 9.5.28, 10.4.18, 11.3.1 that fix the problem described.

Credits

Thanks to TYPO3 core merger Oliver Bartsch who reported and fixed the issue.

References

Record
GHSA-8mq9-fqv8-59wf
CVSS 3.1
6.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVBIT-typo3-2021-32667 No score

TYPO3 is an open source PHP based web content management system. Versions 9.0.0 through 9.5.28, 10.0.0 through 10.4.17, and 11.0.0 through 11.3.0 have a cross-site scripting vulnerability. When Page TSconfig settings are not properly encoded, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability. TYPO3 versions 9.5.29, 10.4.18, 11.3.1 contain a patch for this issue.

Record
BIT-typo3-2021-32667
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
typo3/cms-core
Packagist
9.0.0 up to 9.5.28
9.5.28
typo3/cms-core
Packagist
10.0.0 up to 10.4.18
10.4.18
typo3/cms-core
Packagist
11.0.0 up to 11.3.1
11.3.1
typo3/cms
Packagist
10.0.0 up to 10.4.18
10.4.18
typo3/cms
Packagist
11.0.0 up to 11.3.1
11.3.1
typo3/cms
Packagist
9.0.0 up to 9.5.28
9.5.28
typo3
Bitnami
9.0.0 up to 9.5.287, 10.0.0 up to 10.4.17, 11.0.0 up to 11.3.0
9.5.28710.4.1711.3.0
typo3/cms-core
Packagist
9.0.0 up to 9.5.28, plus listed versions
v9.0.0v9.1.0v9.2.0v9.2.1v9.3.0
Show 32 moreShow less
v9.3.1v9.3.2v9.3.3v9.4.0v9.5.0v9.5.1v9.5.10v9.5.11v9.5.12v9.5.13v9.5.14v9.5.15v9.5.16v9.5.17v9.5.18v9.5.19v9.5.2v9.5.20v9.5.21v9.5.22v9.5.23v9.5.24v9.5.25v9.5.26v9.5.27v9.5.3v9.5.4v9.5.5v9.5.6v9.5.7v9.5.8v9.5.9
9.5.28
typo3/cms-core
Packagist
10.0.0 up to 10.4.18, plus listed versions
v10.0.0v10.1.0v10.2.0v10.2.1v10.2.2
Show 19 moreShow less
v10.3.0v10.4.0v10.4.1v10.4.10v10.4.11v10.4.12v10.4.13v10.4.14v10.4.15v10.4.16v10.4.17v10.4.2v10.4.3v10.4.4v10.4.5v10.4.6v10.4.7v10.4.8v10.4.9
10.4.18
typo3/cms-core
Packagist
11.0.0 up to 11.3.1, plus listed versions
v11.0.0v11.1.0v11.1.1v11.2.0v11.3.0
11.3.1
typo3/cms
Packagist
10.0.0 up to 10.4.18, plus listed versions
v10.0.0v10.1.0v10.2.0v10.2.1v10.2.2
Show 19 moreShow less
v10.3.0v10.4.0v10.4.1v10.4.10v10.4.11v10.4.12v10.4.13v10.4.14v10.4.15v10.4.16v10.4.17v10.4.2v10.4.3v10.4.4v10.4.5v10.4.6v10.4.7v10.4.8v10.4.9
10.4.18
typo3/cms
Packagist
11.0.0 up to 11.3.1, plus listed versions
v11.0.0v11.1.0v11.1.1v11.2.0v11.3.0
11.3.1
typo3/cms
Packagist
9.0.0 up to 9.5.28, plus listed versions
v9.0.0v9.1.0v9.2.0v9.2.1v9.3.0
Show 32 moreShow less
v9.3.1v9.3.2v9.3.3v9.4.0v9.5.0v9.5.1v9.5.10v9.5.11v9.5.12v9.5.13v9.5.14v9.5.15v9.5.16v9.5.17v9.5.18v9.5.19v9.5.2v9.5.20v9.5.21v9.5.22v9.5.23v9.5.24v9.5.25v9.5.26v9.5.27v9.5.3v9.5.4v9.5.5v9.5.6v9.5.7v9.5.8v9.5.9
9.5.28

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-32667 is a medium vulnerability (CVSS 6.4) in Typo3, published July 20, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.60%, the 49th percentile. Fixed in typo3/cms-core 9.5.28.

References

MoveEnter Open