CVE-2021-32682
Multiple vulnerabilities leading to RCE
elFinder is an open-source file manager for web, written in JavaScript using jQuery UI. Several vulnerabilities affect elFinder 2.1.58. These vulnerabilities can allow an attacker to execute arbitrary code and commands on the server hosting the elFinder PHP connector, even with minimal configuration. The issues were patched in version 2.1.59. As a workaround, ensure the connector is not exposed without authentication.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
Multiple vulnerabilities leading to RCE
elFinder is an open-source file manager for web, written in JavaScript using jQuery UI. Several vulnerabilities affect elFinder 2.1.58. These vulnerabilities can allow an attacker to execute arbitrary code and commands on the server hosting the elFinder PHP connector, even with minimal configuration. The issues were patched in version 2.1.59. As a workaround, ensure the connector is not exposed without authentication.
- Record
CVE-2021-32682- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918, CWE-22, CWE-78
- Updated
- 2026-11-02
EUVDEUVD-2021-1418
9.8
elFinder is an open-source file manager for web, written in JavaScript using jQuery UI. Several vulnerabilities affect elFinder 2.1.58. These vulnerabilities can allow an attacker to execute arbitrary code and commands on the server hosting the elFinder PHP connector, even with minimal configuration. The issues were patched in version 2.1.59. As a workaround, ensure the connector is not exposed without authentication.
- Record
EUVD-2021-1418- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wph3-44rj-92pr
9.8
elFinder before 2.1.59 contains multiple vulnerabilities leading to RCE
Impact
We recently fixed several vulnerabilities affect elFinder 2.1.58. These vulnerabilities can allow an attacker to execute arbitrary code and commands on the server hosting the elFinder PHP connector, even with the minimal configuration.
Patches
The issues were addressed in our last release, 2.1.59.
Workarounds
If you can't update to 2.1.59, make sure your connector is not exposed without authentication.
Reference
Further technical details will be disclosed on https://blog.sonarsource.com/tag/security after some time.
For more information
If you have any questions or comments about this advisory, you can contact: - The original reporters, by sending an email to [email protected]; - The maintainers, by opening an issue on this repository.
- Record
GHSA-wph3-44rj-92pr- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-78, CWE-918
- Updated
- 2026-11-02
NVD
9.8
elFinder is an open-source file manager for web, written in JavaScript using jQuery UI. Several vulnerabilities affect elFinder 2.1.58. These vulnerabilities can allow an attacker to execute arbitrary code and commands on the server hosting the elFinder PHP connector, even with minimal configuration. The issues were patched in version 2.1.59. As a workaround, ensure the connector is not exposed without authentication.
- Record
CVE-2021-32682- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-22, CWE-78, CWE-918
- Updated
- 2026-11-02
OSV
9.8
elFinder is an open-source file manager for web, written in JavaScript using jQuery UI. Several vulnerabilities affect elFinder 2.1.58. These vulnerabilities can allow an attacker to execute arbitrary code and commands on the server hosting the elFinder PHP connector, even with minimal configuration. The issues were patched in version 2.1.59. As a workaround, ensure the connector is not exposed without authentication.
- Record
CVE-2021-32682- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-wph3-44rj-92pr
9.8
elFinder before 2.1.59 contains multiple vulnerabilities leading to RCE
Impact
We recently fixed several vulnerabilities affect elFinder 2.1.58. These vulnerabilities can allow an attacker to execute arbitrary code and commands on the server hosting the elFinder PHP connector, even with the minimal configuration.
Patches
The issues were addressed in our last release, 2.1.59.
Workarounds
If you can't update to 2.1.59, make sure your connector is not exposed without authentication.
Reference
Further technical details will be disclosed on https://blog.sonarsource.com/tag/security after some time.
For more information
If you have any questions or comments about this advisory, you can contact: - The original reporters, by sending an email to [email protected]; - The maintainers, by opening an issue on this repository.
- Record
GHSA-wph3-44rj-92pr- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-78, CWE-918
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
studio-42/elfinderPackagist |
before 2.1.59 | 2.1.59 |
studio-42/elfinderPackagist |
before 2.1.59, plus listed versions 2.0.32.0.42.0.52.0.62.0.7 Show 45 moreShow less2.0.82.0.92.1.02.1.12.1.102.1.112.1.122.1.132.1.142.1.152.1.162.1.172.1.182.1.192.1.22.1.202.1.212.1.222.1.232.1.242.1.252.1.262.1.272.1.282.1.292.1.32.1.302.1.312.1.322.1.332.1.342.1.352.1.362.1.372.1.382.1.392.1.42.1.402.1.412.1.422.1.432.1.442.1.452.1.462.1.47 |
2.1.59 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Metasploit | elFinder Archive Command Injection | 2021-06-13 |
| Nuclei | elFinder 2.1.58 - Remote Code Execution |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, Metasploit, Nuclei, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-32682 is a critical vulnerability (CVSS 9.8) in Std42 Elfinder, published June 14, 2021. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 69.9%, the 99th percentile. Fixed in studio-42/elfinder 2.1.59.
References
github.com/Studio-42/elFinder/security/advisories/GHSA-wph3-44rj-92pr
github.com/Studio-42/elFinder/commit/a106c350b7dfe666a81d6b576816db9fe0899b17
packetstormsecurity.com/files/164173/elFinder-Archive-Command-Injection.html
blog.sonarsource.com/elfinder-case-study-of-web-file-manager-vulnerabilities
github.com/Studio-42/elFinder/security/advisories/GHSA-qm58-cvvm-c5qr
nvd.nist.gov/vuln/detail/CVE-2021-32682
github.com/advisories/GHSA-wph3-44rj-92pr
github.com/Studio-42/elFinder
Left out here: 16 versions. The JSON record has them.