CVE-2021-32921
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for...
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a timing attack to reveal the contents of secret strings to an attacker.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.9
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a timing attack to reveal the contents of secret strings to an attacker.
- Record
CVE-2021-32921- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:N - Weakness
- CWE-362
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a timing attack to reveal the contents of secret strings to an attacker.
- Record
CVE-2021-32921- Updated
- 2026-11-02
EUVDEUVD-2021-19643 No score
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a timing attack to reveal the contents of secret strings to an attacker.
- Record
EUVD-2021-19643- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vh63-h6gp-hw6w
5.9
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for...
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a timing attack to reveal the contents of secret strings to an attacker.
- Record
GHSA-vh63-h6gp-hw6w- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-362
- Updated
- 2026-11-02
OSVALPINE-CVE-2021-32921
5.9
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a timing attack to reveal the contents of secret strings to an attacker.
- Record
ALPINE-CVE-2021-32921- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-03
OSV
5.9
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a timing attack to reveal the contents of secret strings to an attacker.
- Record
CVE-2021-32921- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-32921
5.9
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a timing attack to reveal the contents of secret strings to an attacker.
- Record
DEBIAN-CVE-2021-32921- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-32921
5.9
An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a timing attack to reveal the contents of secret strings to an attacker.
- Record
UBUNTU-CVE-2021-32921- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
prosodyAlpine:v3.12 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.13 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.14 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.15 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.16 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.17 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.18 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.19 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.20 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.21 |
before 0.11.9-r0 | 0.11.9-r0 |
Show 12 moreShow less
| Package | Affected | Fixed |
|---|---|---|
prosodyAlpine:v3.22 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.23 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyAlpine:v3.24 |
before 0.11.9-r0 | 0.11.9-r0 |
prosodyDebian:12 |
before 0.11.9-1 | 0.11.9-1 |
prosodyDebian:13 |
before 0.11.9-1 | 0.11.9-1 |
prosodyDebian:14 |
before 0.11.9-1 | 0.11.9-1 |
prosodyDebian:9 From an advisory covering 2 CVEs |
before 0.9.12-2+deb9u3, plus listed versions 0.9.12-20.9.12-2+deb9u10.9.12-2+deb9u2 |
0.9.12-2+deb9u3 |
prosodyDebian:10 From an advisory covering 5 CVEs |
before 0.11.2-1+deb10u1, plus listed versions 0.11.2-1 |
0.11.2-1+deb10u1 |
prosodyUbuntu:16.04:LTS |
All versions, plus listed versions 0.9.8-10.9.9-10.9.10-1 |
None known |
prosodyUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 0.9.12-20.10.0-10.10.0-1build10.10.0-1ubuntu0.1~esm1 |
None known |
prosodyUbuntu:20.04:LTS |
All versions, plus listed versions 0.11.2-10.11.3-10.11.4-1 |
None known |
prosodyUbuntu:22.04:LTS |
All versions, plus listed versions 0.11.10-10.11.10-1build10.11.10-1build20.11.11-10.11.11-20.11.12-10.11.13-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected, aliases, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-32921 is a medium vulnerability (CVSS 5.9) in Prosody, published May 13, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.60%, the 75th percentile. Fixed in prosody 0.11.9-r0.
References
blog.prosody.im/prosody-0.11.9-released
openwall.com/lists/oss-security/2021/05/13/1
openwall.com/lists/oss-security/2021/05/14/2
debian.org/security/2021/dsa-4916
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6MFFBZWXKPZEVZNQSVJNCUE7WRF3T7DG
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LWJ2DG2DFJOEFEWOUN26IMYYWGSA2ZEE
Show 17 moreShow less
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GUN63AHEWB2WRROJHU3BVJRWLONCT2B7
security.gentoo.org/glsa/202105-15
lists.debian.org/debian-lts-announce/2021/06/msg00016.html
lists.debian.org/debian-lts-announce/2021/06/msg00018.html
nvd.nist.gov/vuln/detail/CVE-2021-32921
lists.fedoraproject.org/archives/list/[email protected]/message/6MFFBZWXKPZEVZNQSVJNCUE7WRF3T7DG
lists.fedoraproject.org/archives/list/[email protected]/message/GUN63AHEWB2WRROJHU3BVJRWLONCT2B7
lists.fedoraproject.org/archives/list/[email protected]/message/LWJ2DG2DFJOEFEWOUN26IMYYWGSA2ZEE
github.com/advisories/GHSA-vh63-h6gp-hw6w
security.alpinelinux.org/vuln/CVE-2021-32921
security-tracker.debian.org/tracker/CVE-2021-32921
ubuntu.com/security/CVE-2021-32921
prosody.im/security/advisory_20210512.txt
hg.prosody.im/trunk/rev/c98aebe601f9
hg.prosody.im/trunk/rev/13b84682518e
hg.prosody.im/trunk/rev/6f56170ea986
cve.org/CVERecord?id=CVE-2021-32921