CVE-2021-33036
Apache Hadoop Privilege escalation vulnerability
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
- Record
CVE-2021-33036- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.0 High
AV:N/AC:L/Au:S/C:C/I:C/A:C - Weakness
- CWE-24, CWE-264, CWE-22
- Updated
- 2026-11-02
CVE List No score
Apache Hadoop Privilege escalation vulnerability
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
- Record
CVE-2021-33036- Weakness
- CWE-264, CWE-24
- Updated
- 2026-11-02
EUVDEUVD-2022-5933 No score
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
- Record
EUVD-2022-5933- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-58jx-f5rf-qgqf
8.8
User account escalation in Apache Hadoop
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
- Record
GHSA-58jx-f5rf-qgqf- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-502
- Updated
- 2026-11-02
OSV
8.8
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
- Record
CVE-2021-33036- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-58jx-f5rf-qgqf
8.8
User account escalation in Apache Hadoop
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
- Record
GHSA-58jx-f5rf-qgqf- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-502
- Updated
- 2026-11-02
OSVOESA-2022-2016
8.8
hadoop security update
Apache Hadoop is a framework that allows for the distributed processing of large data sets across clusters of computers using simple programming models. It is designed to scale up from single servers to thousands of machines, each offering local computation and storage.
Security Fix(es):
In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.(CVE-2021-33036)
- Record
OESA-2022-2016- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.hadoop:hadoop-yarn-server-commonMaven |
2.2.0 up to 2.10.2 | 2.10.2 |
org.apache.hadoop:hadoop-yarn-server-commonMaven |
3.0.0 up to 3.2.3 | 3.2.3 |
org.apache.hadoop:hadoop-yarn-server-commonMaven |
3.3.0 up to 3.3.2 | 3.3.2 |
org.apache.hadoop:hadoop-yarn-server-commonMaven |
2.2.0 up to 2.10.2, plus listed versions 2.10.02.10.12.3.02.4.02.4.1 Show 26 moreShow less2.5.02.5.12.5.22.6.02.6.12.6.22.6.32.6.42.6.52.7.02.7.12.7.22.7.32.7.42.7.52.7.62.7.72.8.02.8.12.8.22.8.32.8.42.8.52.9.02.9.12.9.2 |
2.10.2 |
org.apache.hadoop:hadoop-yarn-server-commonMaven |
3.0.0 up to 3.2.3, plus listed versions 3.0.13.0.23.0.33.1.03.1.1 Show 6 moreShow less3.1.23.1.33.1.43.2.03.2.13.2.2 |
3.2.3 |
org.apache.hadoop:hadoop-yarn-server-commonMaven |
3.3.0 up to 3.3.2, plus listed versions 3.3.1 |
3.3.2 |
hadoopopenEuler:20.03-LTS-SP1 |
before 3.3.4-1.oe1 | 3.3.4-1.oe1 |
hadoopopenEuler:20.03-LTS-SP3 |
before 3.3.4-1.oe1 | 3.3.4-1.oe1 |
hadoopopenEuler:22.03-LTS |
before 3.3.4-1.oe2203 | 3.3.4-1.oe2203 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-33036 is a high vulnerability (CVSS 8.8) in Apache Hadoop, published June 15, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.03%, the 90th percentile. Fixed in org.apache.hadoop:hadoop-yarn-server-common 2.10.2.
References
lists.apache.org/thread/ctr84rmo3xd2tzqcx2b277c8z692vhl5
openwall.com/lists/oss-security/2022/06/15/2
security.netapp.com/advisory/ntap-20220722-0003
nvd.nist.gov/vuln/detail/CVE-2021-33036
github.com/apache/hadoop/commit/227d64ab59e8aa6477769b2542ad0cd7a6d855cb
github.com/apache/hadoop/commit/45801fba8b00257ab32c02a7d1a05948ba687a49