CVE-2021-33192
Display information UI XSS
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
- Record
CVE-2021-33192- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Display information UI XSS
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
- Record
CVE-2021-33192- Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2021-1819 No score
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
- Record
EUVD-2021-1819- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-phwj-86vx-cfjc
6.1
Cross-site scripting in Apache Jena Fuseki
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
- Record
GHSA-phwj-86vx-cfjc- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
- Record
CVE-2021-33192- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-33192
6.1
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
- Record
DEBIAN-CVE-2021-33192- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-phwj-86vx-cfjc
6.1
Cross-site scripting in Apache Jena Fuseki
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
- Record
GHSA-phwj-86vx-cfjc- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-33192
6.1
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
- Record
UBUNTU-CVE-2021-33192- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.jena:jena-fusekiMaven |
2.0.0 to 4.0.0 | 4.1.0 |
apache-jenaDebian:12 |
before 4.5.0-1 | 4.5.0-1 |
apache-jenaDebian:13 |
before 4.5.0-1 | 4.5.0-1 |
apache-jenaDebian:14 |
before 4.5.0-1 | 4.5.0-1 |
org.apache.jena:jena-fusekiMaven |
2.0.0 up to 4.1.0, plus listed versions 2.3.02.3.12.4.02.4.12.5.0 Show 17 moreShow less2.6.03.10.03.11.03.12.03.13.03.13.13.14.03.15.03.16.03.17.03.4.03.5.03.6.03.7.03.8.03.9.04.0.0 |
4.1.0 |
apache-jenaUbuntu:22.04:LTS |
All versions, plus listed versions 3.17.0-13.17.0-23.17.0-3 |
None known |
apache-jenaUbuntu:24.04:LTS |
All versions, plus listed versions 4.5.0-24.9.0-1 |
None known |
apache-jenaUbuntu:25.10 |
All versions, plus listed versions 4.9.0-1 |
None known |
apache-jenaUbuntu:26.10 |
All versions, plus listed versions 4.9.0-1build1 |
None known |
apache-jenaUbuntu:26.04:LTS |
All versions, plus listed versions 4.9.0-14.9.0-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-33192 is a medium vulnerability (CVSS 6.1) in Apache Jena Fuseki, published July 5, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.88%, the 86th percentile. Fixed in org.apache.jena:jena-fuseki 4.1.0.
References
lists.apache.org/thread.html/r684d8943d755a96fe90f8cd8df196737b6bde3f2b74e15a9bd479975%40%3Cusers.jena.apache.org%3E
nvd.nist.gov/vuln/detail/CVE-2021-33192
github.com/advisories/GHSA-phwj-86vx-cfjc
security-tracker.debian.org/tracker/CVE-2021-33192
ubuntu.com/security/CVE-2021-33192
lists.apache.org/thread/sq6q94q0prqwr9vdm2wptglcq1kv98k8
cve.org/CVERecord?id=CVE-2021-33192