Every CVE Search/ Get API key

CVE-2021-33204

In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary...

9.8 CriticalFix available

In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary code execution can be achieved via SECURITY DEFINER functions because an explicit search_path is not set.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.20%Up 1.1 points since May 20, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary code execution can be achieved via SECURITY DEFINER functions because an explicit search_path is not set.

Record
CVE-2021-33204
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary code execution can be achieved via SECURITY DEFINER functions because an explicit search_path is not set.

Record
CVE-2021-33204
Updated
2026-11-02
EUVDEUVD-2021-19916 No score

In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary code execution can be achieved via SECURITY DEFINER functions because an explicit search_path is not set.

Record
EUVD-2021-19916
Updated
2026-11-03
GitHub AdvisoriesGHSA-p3fg-5jpr-hm49 9.8

In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary...

In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary code execution can be achieved via SECURITY DEFINER functions because an explicit search_path is not set.

Record
GHSA-p3fg-5jpr-hm49
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
OSV 9.8

In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary code execution can be achieved via SECURITY DEFINER functions because an explicit search_path is not set.

Record
CVE-2021-33204
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-33204 9.8

In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary code execution can be achieved via SECURITY DEFINER functions because an explicit search_path is not set.

Record
DEBIAN-CVE-2021-33204
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-33204 9.8

In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary code execution can be achieved via SECURITY DEFINER functions because an explicit search_path is not set.

Record
UBUNTU-CVE-2021-33204
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pg-partman
Debian:12
before 4.5.1-1
4.5.1-1
pg-partman
Debian:13
before 4.5.1-1
4.5.1-1
pg-partman
Debian:14
before 4.5.1-1
4.5.1-1
pg-partman
Ubuntu:16.04:LTS
All versions, plus listed versions
2.2.2-12.2.2-2
None known
pg-partman
Ubuntu:18.04:LTS
All versions, plus listed versions
2.6.3-13.1.0-13.1.1-13.1.2-1
None known
pg-partman
Ubuntu:20.04:LTS
All versions, plus listed versions
4.0.0-14.2.0-14.2.2-14.3.0-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-33204 is a critical vulnerability (CVSS 9.8) in Pgxn Pg Partman, published May 19, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.20%, the 82nd percentile. Fixed in pg-partman 4.5.1-1.

References

MoveEnter Open