Every CVE Search/ Get API key

CVE-2021-3345

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt before 1.9.1 has a heap-based buffer...

7.8 HighPublic exploit

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt version 1.9.0 has a heap-based buffer overflow when the digest final function sets a large count value. It is recommended to upgrade to 1.9.1 or later.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.06%Down 4.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt version 1.9.0 has a heap-based buffer overflow when the digest final function sets a large count value. It is recommended to upgrade to 1.9.1 or later.

Record
CVE-2021-3345
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt version 1.9.0 has a heap-based buffer overflow when the digest final function sets a large count value. It is recommended to upgrade to 1.9.1 or later.

Record
CVE-2021-3345
Updated
2026-11-02
EUVDEUVD-2021-26676 No score

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt version 1.9.0 has a heap-based buffer overflow when the digest final function sets a large count value. It is recommended to upgrade to 1.9.1 or later.

Record
EUVD-2021-26676
Updated
2026-11-03
GitHub AdvisoriesGHSA-pf53-rq8f-rwqx 7.8

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt before 1.9.1 has a heap-based buffer...

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt before 1.9.1 has a heap-based buffer overflow when the digest final function sets a large count value.

Record
GHSA-pf53-rq8f-rwqx
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSVBELL-CVE-2021-3345 7.8

CVE-2021-3345 does not affect BellSoft software

Record
BELL-CVE-2021-3345
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 7.8

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt version 1.9.0 has a heap-based buffer overflow when the digest final function sets a large count value. It is recommended to upgrade to 1.9.1 or later.

Record
CVE-2021-3345
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-3345 7.8

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt version 1.9.0 has a heap-based buffer overflow when the digest final function sets a large count value. It is recommended to upgrade to 1.9.1 or later.

Record
UBUNTU-CVE-2021-3345
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:10941-1 No score

libgcrypt-cavs-1.9.4-1.2 on GA media

These are all security issues fixed in the libgcrypt-cavs-1.9.4-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10941-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libgcrypt
openSUSE:Tumbleweed
From an advisory covering 7 CVEs
before 1.9.4-1.2
1.9.4-1.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubMLGRadish/CVE-2021-33452021-01-31
PoC in GitHubSpiralBL0CK/CVE-2021-33452024-02-29

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-3345 is a high vulnerability (CVSS 7.8) in Gnupg Libgcrypt, published January 29, 2021. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.06%, the 64th percentile. No source names a fixed version.

References

Show 13 moreShow less
MoveEnter Open