CVE-2021-33464
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in...
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
- Record
CVE-2021-33464- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
- Record
CVE-2021-33464- Updated
- 2026-11-02
EUVDEUVD-2021-20168 No score
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
- Record
EUVD-2021-20168- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j4jc-fh4v-27gw
5.5
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in...
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
- Record
GHSA-j4jc-fh4v-27gw- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSVAZL-10334
5.5
CVE-2021-33464 affecting package yasm 1.3.0-17
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
- Record
AZL-10334- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVAZL-35374
5.5
CVE-2021-33464 affecting package yasm 1.3.0-17
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
- Record
AZL-35374- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-05
Show 5 moreShow less
OSV
5.5
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
- Record
CVE-2021-33464- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-33464
5.5
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
- Record
DEBIAN-CVE-2021-33464- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVJLSEC-2026-594
5.5
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
- Record
JLSEC-2026-594- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVOESA-2025-1526
5.5
yasm security update
Yasm is a complete rewrite of the NASM assembler under the “new” BSD License.
Security Fix(es):
An issue was discovered in yasm version 1.3.0. There is a NULL pointer dereference in yasm_expr_get_intnum() in libyasm/expr.c.(CVE-2021-33454)
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.(CVE-2021-33464)
yasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf. Note: This has been disputed by third parties who argue this is a bug and not a security issue because yasm is a standalone program not designed to run untrusted code.(CVE-2023-29579)
- Record
OESA-2025-1526- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-33464
5.5
An issue was discovered in yasm version 1.3.0. There is a heap-buffer-overflow in inc_fopen() in modules/preprocs/nasm/nasm-pp.c.
- Record
UBUNTU-CVE-2021-33464- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
yasmAzure Linux:2 |
through 1.3.0-17 | None known |
yasmAzure Linux:3 |
through 1.3.0-17 | None known |
yasmDebian:12 |
All versions, plus listed versions 1.3.0-41.3.0-51.3.0-61.3.0-71.3.0-8 |
None known |
yasmDebian:13 |
before 1.3.0-7 | 1.3.0-7 |
yasmDebian:14 |
before 1.3.0-7 | 1.3.0-7 |
YASM_jllJulia |
All versions | None known |
yasmopenEuler:24.03-LTS-SP1 From an advisory covering 3 CVEs |
before 1.3.0-13.oe2403sp1 | 1.3.0-13.oe2403sp1 |
yasmopenEuler:20.03-LTS-SP4 From an advisory covering 3 CVEs |
before 1.3.0-13.oe2003sp4 | 1.3.0-13.oe2003sp4 |
yasmopenEuler:22.03-LTS-SP3 From an advisory covering 3 CVEs |
before 1.3.0-13.oe2203sp3 | 1.3.0-13.oe2203sp3 |
yasmopenEuler:22.03-LTS-SP4 From an advisory covering 3 CVEs |
before 1.3.0-13.oe2203sp4 | 1.3.0-13.oe2203sp4 |
Show 9 moreShow less
| Package | Affected | Fixed |
|---|---|---|
yasmopenEuler:24.03-LTS From an advisory covering 3 CVEs |
before 1.3.0-13.oe2403 | 1.3.0-13.oe2403 |
yasmUbuntu:16.04:LTS |
All versions, plus listed versions 1.3.0-2 |
None known |
yasmUbuntu:18.04:LTS |
All versions, plus listed versions 1.3.0-21.3.0-2build1 |
None known |
yasmUbuntu:20.04:LTS |
All versions, plus listed versions 1.3.0-2build11.3.0-2ubuntu1 |
None known |
yasmUbuntu:22.04:LTS |
All versions, plus listed versions 1.3.0-2.1 |
None known |
yasmUbuntu:24.04:LTS |
All versions, plus listed versions 1.3.0-4 |
None known |
yasmUbuntu:25.10 |
All versions, plus listed versions 1.3.0-51.3.0-7 |
None known |
yasmUbuntu:26.10 |
All versions, plus listed versions 1.3.0-8 |
None known |
yasmUbuntu:26.04:LTS |
All versions, plus listed versions 1.3.0-71.3.0-8 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-33464 is a medium vulnerability (CVSS 5.5) in Tortall Yasm, published July 26, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 25th percentile. Fixed in yasm 1.3.0-7.