Every CVE Search/ Get API key

CVE-2021-33815

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because...

8.8 HighFix available

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because dc_count is not strictly checked.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.36%Up 0.9 points since Jun 4, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because dc_count is not strictly checked.

Record
CVE-2021-33815
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-129
Updated
2026-11-02
CVE List No score

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because dc_count is not strictly checked.

Record
CVE-2021-33815
Updated
2026-11-02
EUVDEUVD-2021-20491 No score

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because dc_count is not strictly checked.

Record
EUVD-2021-20491
Updated
2026-11-03
GitHub AdvisoriesGHSA-gcpj-pp7m-cw8v 8.8

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because...

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because dc_count is not strictly checked.

Record
GHSA-gcpj-pp7m-cw8v
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-129
Updated
2026-11-02
OSVALPINE-CVE-2021-33815 8.8

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because dc_count is not strictly checked.

Record
ALPINE-CVE-2021-33815
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.8

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because dc_count is not strictly checked.

Record
CVE-2021-33815
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-07
OSVJLSEC-2025-114 8.8

`dwa_uncompress` in `libavcodec/exr.c` in FFmpeg 4.4 allows an out-of-bounds array access because...

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because dc_count is not strictly checked.

Record
JLSEC-2025-114
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Updated
2026-11-02
OSVUBUNTU-CVE-2021-33815 8.8

dwa_uncompress in libavcodec/exr.c in FFmpeg 4.4 allows an out-of-bounds array access because dc_count is not strictly checked.

Record
UBUNTU-CVE-2021-33815
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:10754-1 No score

ffmpeg-4-4.4-5.2 on GA media

These are all security issues fixed in the ffmpeg-4-4.4-5.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10754-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.14
before 4.4-r1
4.4-r1
ffmpeg
Alpine:v3.15
before 4.4-r1
4.4-r1
ffmpeg
Alpine:v3.16
before 4.4-r1
4.4-r1
ffmpeg
Alpine:v3.17
before 4.4-r1
4.4-r1
ffmpeg
Alpine:v3.18
before 4.4-r1
4.4-r1
ffmpeg
Alpine:v3.19
before 4.4-r1
4.4-r1
ffmpeg
Alpine:v3.20
before 4.4-r1
4.4-r1
ffmpeg
Alpine:v3.21
before 4.4-r1
4.4-r1
ffmpeg
Alpine:v3.22
before 4.4-r1
4.4-r1
ffmpeg
Alpine:v3.23
before 4.4-r1
4.4-r1
Show 10 moreShow less
Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.24
before 4.4-r1
4.4-r1
ffmpeg4
Alpine:v3.16
before 4.4-r1
4.4-r1
ffmpeg4
Alpine:v3.17
before 4.4-r1
4.4-r1
ffmpeg4
Alpine:v3.18
before 4.4-r1
4.4-r1
ffmpeg4
Alpine:v3.19
before 4.4-r1
4.4-r1
ffmpeg4
Alpine:v3.20
before 4.4-r1
4.4-r1
ffmpeg4
Alpine:v3.21
before 4.4-r1
4.4-r1
ffmpeg4
Alpine:v3.22
before 4.4-r1
4.4-r1
FFMPEG_jll
Julia
4.4.0+0 up to 4.4.2+0
4.4.2+0
ffmpeg-4
openSUSE:Tumbleweed
From an advisory covering 46 CVEs
before 4.4-5.2
4.4-5.2

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-33815 is a high vulnerability (CVSS 8.8) in Ffmpeg, published June 3, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.36%, the 71st percentile. Fixed in ffmpeg 4.4-r1.

References

Show 47 moreShow less
MoveEnter Open