CVE-2021-34055
jhead 3.06 is vulnerable to Buffer Overflow via exif.c in function Put16u.
jhead 3.06 is vulnerable to Buffer Overflow via exif.c in function Put16u.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
jhead 3.06 is vulnerable to Buffer Overflow via exif.c in function Put16u.
- Record
CVE-2021-34055- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List
7.8
jhead 3.06 is vulnerable to Buffer Overflow via exif.c in function Put16u.
- Record
CVE-2021-34055- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2021-20725
7.8
jhead 3.06 is vulnerable to Buffer Overflow via exif.c in function Put16u.
- Record
EUVD-2021-20725- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-fxjw-w469-wq6w
7.8
jhead 3.06 is vulnerable to Buffer Overflow via exif.c in function Put16u.
jhead 3.06 is vulnerable to Buffer Overflow via exif.c in function Put16u.
- Record
GHSA-fxjw-w469-wq6w- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSV
7.8
jhead 3.06 is vulnerable to Buffer Overflow via exif.c in function Put16u.
- Record
CVE-2021-34055- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-34055
7.8
jhead 3.06 is vulnerable to Buffer Overflow via exif.c in function Put16u.
- Record
DEBIAN-CVE-2021-34055- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2021-34055
7.8
jhead 3.06 is vulnerable to Buffer Overflow via exif.c in function Put16u.
- Record
UBUNTU-CVE-2021-34055- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2022:10202-1 No score
Security update for jhead
This update for jhead fixes the following issues:
- CVE-2021-34055: Fix out of bounds write in ClearOrientation() due to unchecked error (boo#1205167)
- Record
openSUSE-SU-2022:10202-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2022:10203-1 No score
Security update for jhead
This update for jhead fixes the following issues:
- CVE-2021-34055: Fix out of bounds write in ClearOrientation() due to unchecked error (boo#1205167)
- Record
openSUSE-SU-2022:10203-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:12499-1 No score
jhead-3.06.0.1-3.1 on GA media
These are all security issues fixed in the jhead-3.06.0.1-3.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:12499-1- Updated
- 2026-11-02
OSVUSN-6108-1 No score
Jhead vulnerabilities
It was discovered that Jhead did not properly handle certain crafted images while rotating them. An attacker could possibly use this issue to crash Jhead, resulting in a denial of service. (CVE-2021-34055)
Kyle Brown discovered that Jhead did not properly handle certain crafted images while regenerating the Exif thumbnail. An attacker could possibly use this issue to execute arbitrary commands. (CVE-2022-41751)
- Record
USN-6108-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
jheadDebian:12 |
before 1:3.06.0.1-5 | 1:3.06.0.1-5 |
jheadDebian:13 |
before 1:3.06.0.1-5 | 1:3.06.0.1-5 |
jheadDebian:14 |
before 1:3.06.0.1-5 | 1:3.06.0.1-5 |
jheadDebian:10 From an advisory covering 2 CVEs |
before 1:3.00-8+deb10u1, plus listed versions 1:3.00-8 |
1:3.00-8+deb10u1 |
jheadDebian:11 From an advisory covering 2 CVEs |
before 1:3.04-6+deb11u1, plus listed versions 1:3.04-6 |
1:3.04-6+deb11u1 |
jheadUbuntu:Pro:14.04:LTS |
before 1:2.97-1+deb8u2ubuntu0.1~esm2, plus listed versions 1:2.97-11:2.97-1+deb8u1build0.14.04.11:2.97-1+deb8u2build0.14.04.1~esm11:2.97-1+deb8u2ubuntu0.1~esm1 |
1:2.97-1+deb8u2ubuntu0.1~esm2 |
jheadUbuntu:Pro:16.04:LTS |
before 1:3.00-4+deb9u1ubuntu0.1~esm2, plus listed versions 1:3.00-11:3.00-21:3.00-31:3.00-4+deb9u1build0.16.04.11:3.00-4+deb9u1ubuntu0.1~esm1 |
1:3.00-4+deb9u1ubuntu0.1~esm2 |
jheadUbuntu:18.04:LTS |
before 1:3.00-8~ubuntu0.2, plus listed versions 1:3.00-41:3.00-51:3.00-61:3.00-8~build0.18.04.11:3.00-8~ubuntu0.1 |
1:3.00-8~ubuntu0.2 |
jheadUbuntu:20.04:LTS |
before 1:3.04-1ubuntu0.2, plus listed versions 1:3.03-31:3.04-11:3.04-1ubuntu0.1 |
1:3.04-1ubuntu0.2 |
jheadUbuntu:22.04:LTS |
before 1:3.06.0.1-2ubuntu0.22.04.1, plus listed versions 1:3.04-61:3.06.0.1-2 |
1:3.06.0.1-2ubuntu0.22.04.1 |
Show 10 moreShow less
| Package | Affected | Fixed |
|---|---|---|
jheadUbuntu:Pro:14.04:LTS From an advisory covering 2 CVEs |
before 1:2.97-1+deb8u2ubuntu0.1~esm2, plus listed versions 1:2.97-11:2.97-1+deb8u1build0.14.04.11:2.97-1+deb8u2build0.14.04.1~esm11:2.97-1+deb8u2ubuntu0.1~esm1 |
1:2.97-1+deb8u2ubuntu0.1~esm2 |
jheadUbuntu:Pro:16.04:LTS From an advisory covering 2 CVEs |
before 1:3.00-4+deb9u1ubuntu0.1~esm2, plus listed versions 1:3.00-11:3.00-21:3.00-31:3.00-4+deb9u1build0.16.04.11:3.00-4+deb9u1ubuntu0.1~esm1 |
1:3.00-4+deb9u1ubuntu0.1~esm2 |
jheadUbuntu:18.04:LTS From an advisory covering 2 CVEs |
before 1:3.00-8~ubuntu0.2, plus listed versions 1:3.00-41:3.00-51:3.00-61:3.00-8~build0.18.04.11:3.00-8~ubuntu0.1 |
1:3.00-8~ubuntu0.2 |
jheadUbuntu:20.04:LTS From an advisory covering 2 CVEs |
before 1:3.04-1ubuntu0.2, plus listed versions 1:3.03-31:3.04-11:3.04-1ubuntu0.1 |
1:3.04-1ubuntu0.2 |
jheadUbuntu:22.04:LTS From an advisory covering 2 CVEs |
before 1:3.06.0.1-2ubuntu0.22.04.1, plus listed versions 1:3.04-61:3.06.0.1-2 |
1:3.06.0.1-2ubuntu0.22.04.1 |
jheadSUSE:Package Hub 15 SP4 |
before 3.06.0.1-bp154.2.6.1 | 3.06.0.1-bp154.2.6.1 |
jheadopenSUSE:Leap 15.4 |
before 3.06.0.1-bp154.2.6.1 | 3.06.0.1-bp154.2.6.1 |
jheadSUSE:Package Hub 15 SP3 |
before 3.00-bp153.3.6.1 | 3.00-bp153.3.6.1 |
jheadopenSUSE:Leap 15.3 |
before 3.00-bp153.3.6.1 | 3.00-bp153.3.6.1 |
jheadopenSUSE:Tumbleweed |
before 3.06.0.1-3.1 | 3.06.0.1-3.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-34055 is a high vulnerability (CVSS 7.8) in Jhead Project Jhead, published November 4, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 39th percentile. Fixed in jhead 1:3.06.0.1-5.
References
github.com/Matthias-Wandel/jhead/issues/36
lists.debian.org/debian-lts-announce/2022/12/msg00004.html
debian.org/security/2022/dsa-5294
nvd.nist.gov/vuln/detail/CVE-2021-34055
github.com/advisories/GHSA-fxjw-w469-wq6w
security-tracker.debian.org/tracker/CVE-2021-34055
Show 8 moreShow less
ubuntu.com/security/CVE-2021-34055
ubuntu.com/security/notices/USN-6108-1
cve.org/CVERecord?id=CVE-2021-34055
ubuntu.com/security/CVE-2022-41751
lists.opensuse.org/archives/list/[email protected]/thread/VFW7LPBWACIK5T4XBHVQEUEXUGR6W2Q7
bugzilla.suse.com/1205167
suse.com/security/cve/CVE-2021-34055
lists.opensuse.org/archives/list/[email protected]/thread/GQXG7P6ITEZEB7XWYDWI6NI2XSYXGLMF