CVE-2021-3466
A flaw was found in libmicrohttpd in versions before 0.9.71. A missing bounds check in the...
A flaw was found in libmicrohttpd. A missing bounds check in the post_process_urlencoded function leads to a buffer overflow, allowing a remote attacker to write arbitrary data in an application that uses libmicrohttpd. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Only version 0.9.70 is vulnerable.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
A flaw was found in libmicrohttpd. A missing bounds check in the post_process_urlencoded function leads to a buffer overflow, allowing a remote attacker to write arbitrary data in an application that uses libmicrohttpd. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Only version 0.9.70 is vulnerable.
- Record
CVE-2021-3466- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List No score
A flaw was found in libmicrohttpd. A missing bounds check in the post_process_urlencoded function leads to a buffer overflow, allowing a remote attacker to write arbitrary data in an application that uses libmicrohttpd. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Only version 0.9.70 is vulnerable.
- Record
CVE-2021-3466- Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2021-26788 No score
A flaw was found in libmicrohttpd. A missing bounds check in the post_process_urlencoded function leads to a buffer overflow, allowing a remote attacker to write arbitrary data in an application that uses libmicrohttpd. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Only version 0.9.70 is vulnerable.
- Record
EUVD-2021-26788- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vjm5-89cg-7hj8
9.8
A flaw was found in libmicrohttpd in versions before 0.9.71. A missing bounds check in the...
A flaw was found in libmicrohttpd in versions before 0.9.71. A missing bounds check in the post_process_urlencoded function leads to a buffer overflow, allowing a remote attacker to write arbitrary data in an application that uses libmicrohttpd. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
- Record
GHSA-vjm5-89cg-7hj8- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSV
9.8
A flaw was found in libmicrohttpd. A missing bounds check in the post_process_urlencoded function leads to a buffer overflow, allowing a remote attacker to write arbitrary data in an application that uses libmicrohttpd. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Only version 0.9.70 is vulnerable.
- Record
CVE-2021-3466- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-3466
9.8
A flaw was found in libmicrohttpd. A missing bounds check in the post_process_urlencoded function leads to a buffer overflow, allowing a remote attacker to write arbitrary data in an application that uses libmicrohttpd. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Only version 0.9.70 is vulnerable.
- Record
DEBIAN-CVE-2021-3466- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libmicrohttpdDebian:12 |
before 0.9.71-1 | 0.9.71-1 |
libmicrohttpdDebian:13 |
before 0.9.71-1 | 0.9.71-1 |
libmicrohttpdDebian:14 |
before 0.9.71-1 | 0.9.71-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-3466 is a critical vulnerability (CVSS 9.8) in Gnu Libmicrohttpd, published March 25, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.74%, the 95th percentile. Fixed in libmicrohttpd 0.9.71-1.
References
bugzilla.redhat.com/show_bug.cgi?id=1939127
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4334XJNDJPYQNFE6S3S2KUJJ7TMHYCWL
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/K5NEPVGP3L2CZHLZ4UB44PEILHKPDBOG
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/75HDMREKITMGPGE62NP7KE62ZJVLETXN
security.gentoo.org/glsa/202311-08
nvd.nist.gov/vuln/detail/CVE-2021-3466
Show 5 moreShow less
lists.fedoraproject.org/archives/list/[email protected]/message/4334XJNDJPYQNFE6S3S2KUJJ7TMHYCWL
lists.fedoraproject.org/archives/list/[email protected]/message/75HDMREKITMGPGE62NP7KE62ZJVLETXN
lists.fedoraproject.org/archives/list/[email protected]/message/K5NEPVGP3L2CZHLZ4UB44PEILHKPDBOG
github.com/advisories/GHSA-vjm5-89cg-7hj8
security-tracker.debian.org/tracker/CVE-2021-3466