Every CVE Search/ Get API key

CVE-2021-34825

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a...

7.5 HighFix available

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.62%Up 0.2 points since Jun 19, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

Record
CVE-2021-34825
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Weakness
CWE-319
Updated
2026-11-02
CVE List No score

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

Record
CVE-2021-34825
Updated
2026-11-02
EUVDEUVD-2021-21472 No score

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

Record
EUVD-2021-21472
Updated
2026-11-03
GitHub AdvisoriesGHSA-gqwq-mfx3-p24m 7.5

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a...

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

Record
GHSA-gqwq-mfx3-p24m
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-311
Updated
2026-11-02
OSVALPINE-CVE-2021-34825 7.5

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

Record
ALPINE-CVE-2021-34825
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-03
OSV 7.5

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

Record
CVE-2021-34825
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2021-34825 7.5

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

Record
DEBIAN-CVE-2021-34825
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2021-34825 7.5

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.

Record
UBUNTU-CVE-2021-34825
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVMGASA-2021-0382 No score

Updated quassel packages fix a security vulnerability

Quassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system (CVE-2021-34825).

Also, the default IRC server has been changed from Freenode to Libera Chat, as upstream has moved their #quassel channel there.

Record
MGASA-2021-0382
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
quassel
Alpine:v3.14
before 0.13.1-r6
0.13.1-r6
quassel
Alpine:v3.15
before 0.13.1-r6
0.13.1-r6
quassel
Alpine:v3.16
before 0.13.1-r6
0.13.1-r6
quassel
Alpine:v3.17
before 0.13.1-r6
0.13.1-r6
quassel
Alpine:v3.18
before 0.13.1-r6
0.13.1-r6
quassel
Alpine:v3.19
before 0.13.1-r6
0.13.1-r6
quassel
Alpine:v3.20
before 0.13.1-r6
0.13.1-r6
quassel
Alpine:v3.21
before 0.13.1-r6
0.13.1-r6
quassel
Alpine:v3.22
before 0.13.1-r6
0.13.1-r6
quassel
Alpine:v3.23
before 0.13.1-r6
0.13.1-r6
Show 13 moreShow less
Affected packages
PackageAffectedFixed
quassel
Alpine:v3.24
before 0.13.1-r6
0.13.1-r6
quassel
Debian:12
before 1:0.14.0-1
1:0.14.0-1
quassel
Debian:13
before 1:0.14.0-1
1:0.14.0-1
quassel
Debian:14
before 1:0.14.0-1
1:0.14.0-1
quassel
Mageia:8
before 0.13.1-6.2.mga8
0.13.1-6.2.mga8
quassel
Ubuntu:16.04:LTS
All versions, plus listed versions
0.12.2-0ubuntu10.12.2-0ubuntu1.16.04.2
None known
quassel
Ubuntu:18.04:LTS
All versions, plus listed versions
1:0.12.4-2ubuntu21:0.12.4-2ubuntu31:0.12.4-3ubuntu11:0.12.4-3ubuntu1.18.04.11:0.12.4-3ubuntu1.18.04.21:0.12.4-3ubuntu1.18.04.3
None known
quassel
Ubuntu:20.04:LTS
All versions, plus listed versions
1:0.13.1-1ubuntu11:0.13.1-2ubuntu11:0.13.1-3ubuntu11:0.13.1-3ubuntu21:0.13.1-3ubuntu2.1
None known
quassel
Ubuntu:22.04:LTS
All versions, plus listed versions
1:0.13.1-3ubuntu31:0.13.1-5ubuntu11:0.14.0-11:0.14.0-1build11:0.14.0-1ubuntu0.22.04.11:0.14.0-1ubuntu0.22.04.4
None known
quassel
Ubuntu:24.04:LTS
All versions, plus listed versions
1:0.14.0-2ubuntu11:0.14.0-2ubuntu21:0.14.0-2ubuntu3
None known
quassel
Ubuntu:25.10
All versions, plus listed versions
1:0.14.0-2ubuntu41:0.14.0-3ubuntu11:0.14.0-3ubuntu2
None known
quassel
Ubuntu:26.10
All versions, plus listed versions
1:0.14.0-4ubuntu21:0.14.0-5ubuntu1
None known
quassel
Ubuntu:26.04:LTS
All versions, plus listed versions
1:0.14.0-3ubuntu21:0.14.0-3ubuntu31:0.14.0-4ubuntu11:0.14.0-4ubuntu2
None known

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-34825 is a high vulnerability (CVSS 7.5) in Quassel-irc Quassel, published June 17, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.62%, the 49th percentile. Fixed in quassel 0.13.1-r6.

References

Show 10 moreShow less
MoveEnter Open