CVE-2021-3515
A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An...
A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.7
A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().
- Record
CVE-2021-3515- CVSS 3.1
- 6.7 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.2 High
AV:L/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-77, CWE-78
- Updated
- 2026-11-02
CVE List No score
A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().
- Record
CVE-2021-3515- Weakness
- CWE-77
- Updated
- 2026-11-02
EUVDEUVD-2021-26833 No score
A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().
- Record
EUVD-2021-26833- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pg8h-w6r7-prw8
6.7
A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An...
A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().
- Record
GHSA-pg8h-w6r7-prw8- CVSS 3.1
- 6.7 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77, CWE-78
- Updated
- 2026-11-02
OSV
6.7
A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().
- Record
CVE-2021-3515- CVSS 3.1
- 6.7 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-3515
6.7
A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().
- Record
DEBIAN-CVE-2021-3515- CVSS 3.1
- 6.7 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-3515
6.7
A shell injection flaw was found in pglogical in versions before 2.3.4 and before 3.6.26. An attacker with CREATEDB privileges on a PostgreSQL server can craft a database name that allows execution of shell commands as the postgresql user when calling pglogical.create_subscription().
- Record
UBUNTU-CVE-2021-3515- CVSS 3.1
- 6.7 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pglogicalDebian:12 |
before 2.3.3-3 | 2.3.3-3 |
pglogicalDebian:13 |
before 2.3.3-3 | 2.3.3-3 |
pglogicalDebian:14 |
before 2.3.3-3 | 2.3.3-3 |
pglogicalUbuntu:18.04:LTS |
All versions, plus listed versions 2.0.0-12.1.0-12.1.1-1 |
None known |
pglogicalUbuntu:20.04:LTS |
All versions, plus listed versions 2.2.2-12.3.0-1 |
None known |
pglogicalUbuntu:22.04:LTS |
All versions, plus listed versions 2.3.3-32.4.0-22.4.1-1 |
None known |
pglogicalUbuntu:24.04:LTS |
All versions, plus listed versions 2.4.3-1ubuntu12.4.4-1 |
None known |
pglogicalUbuntu:25.10 |
All versions, plus listed versions 2.4.5-12.4.5-1build1 |
None known |
pglogicalUbuntu:26.10 |
All versions, plus listed versions 2.4.6-22.4.7-12.4.8-1 |
None known |
pglogicalUbuntu:26.04:LTS |
All versions, plus listed versions 2.4.5-1build12.4.6-12.4.6-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-3515 is a medium vulnerability (CVSS 6.7) in 2ndquadrant Pglogical, published June 1, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 39th percentile. Fixed in pglogical 2.3.3-3.
References
bugzilla.redhat.com/show_bug.cgi?id=1954112
nvd.nist.gov/vuln/detail/CVE-2021-3515
github.com/advisories/GHSA-pg8h-w6r7-prw8
security-tracker.debian.org/tracker/CVE-2021-3515
ubuntu.com/security/CVE-2021-3515
github.com/2ndQuadrant/pglogical/commit/95c0e8981485e09efab6821cf55a4e27b086efe5
cve.org/CVERecord?id=CVE-2021-3515