CVE-2021-35513
Cross-site Scripting in Mermaid
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
- Record
CVE-2021-35513- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
- Record
CVE-2021-35513- Updated
- 2026-11-02
EUVDEUVD-2021-2437 No score
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
- Record
EUVD-2021-2437- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4f6x-49g2-99fm
6.1
Cross-site Scripting in Mermaid
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
- Record
GHSA-4f6x-49g2-99fm- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
- Record
CVE-2021-35513- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-35513
6.1
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
- Record
DEBIAN-CVE-2021-35513- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-4f6x-49g2-99fm
6.1
Cross-site Scripting in Mermaid
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
- Record
GHSA-4f6x-49g2-99fm- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-35513
6.1
Mermaid before 8.11.0 allows XSS when the antiscript feature is used.
- Record
UBUNTU-CVE-2021-35513- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mermaidnpm |
before 8.11.0 | 8.11.0 |
node-mermaidDebian:14 |
before 8.7.0+ds+~cs27.17.17-3, plus listed versions 8.7.0+ds+~cs27.17.17-18.7.0+ds+~cs27.17.17-28.7.0+ds+~cs27.17.17-2~bpo10+1 |
8.7.0+ds+~cs27.17.17-3 |
node-mermaidUbuntu:22.04:LTS |
All versions, plus listed versions 8.7.0+ds+~cs27.17.17-38.13.3+ds+~cs26.13.21-18.13.3+ds+~cs26.13.21-28.13.8+~cs10.4.16-1 |
None known |
node-mermaidUbuntu:26.10 |
All versions, plus listed versions 9.2.2+~2.0.0-19.2.2+~2.0.0-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-35513 is a medium vulnerability (CVSS 6.1) in Mermaid Project Mermaid, published June 27, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. Fixed in mermaid 8.11.0.
References
github.com/mermaid-js/mermaid/issues/2122
github.com/mermaid-js/mermaid/pull/2123
github.com/mermaid-js/mermaid/releases/tag/8.11.0-rc2
nvd.nist.gov/vuln/detail/CVE-2021-35513
github.com/mermaid-js/mermaid/pull/2123/commits/3d22fa5d2435de5acc18de6f88474a6e8675a60e
github.com/advisories/GHSA-4f6x-49g2-99fm
security-tracker.debian.org/tracker/CVE-2021-35513
ubuntu.com/security/CVE-2021-35513
cve.org/CVERecord?id=CVE-2021-35513