CVE-2021-35525
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long...
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long data fields such as multiple concatenated email addresses. NOTE: the PostSRSd maintainer acknowledges "theoretically, this error should never occur ... I'm not sure if there's a reliable way to trigger this condition by an external attacker, but it is a security bug in PostSRSd nevertheless."
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
NVD Score used
5.3
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long data fields such as multiple concatenated email addresses. NOTE: the PostSRSd maintainer acknowledges "theoretically, this error should never occur ... I'm not sure if there's a reliable way to trigger this condition by an external attacker, but it is a security bug in PostSRSd nevertheless."
- Record
CVE-2021-35525- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long data fields such as multiple concatenated email addresses. NOTE: the PostSRSd maintainer acknowledges "theoretically, this error should never occur ... I'm not sure if there's a reliable way to trigger this condition by an external attacker, but it is a security bug in PostSRSd nevertheless."
- Record
CVE-2021-35525- Updated
- 2026-11-02
EUVDEUVD-2021-22161 No score
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long data fields such as multiple concatenated email addresses. NOTE: the PostSRSd maintainer acknowledges "theoretically, this error should never occur ... I'm not sure if there's a reliable way to trigger this condition by an external attacker, but it is a security bug in PostSRSd nevertheless."
- Record
EUVD-2021-22161- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w799-rf9r-4rqc No score
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long...
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long data fields such as multiple concatenated email addresses. NOTE: the PostSRSd maintainer acknowledges "theoretically, this error should never occur ... I'm not sure if there's a reliable way to trigger this condition by an external attacker, but it is a security bug in PostSRSd nevertheless."
- Record
GHSA-w799-rf9r-4rqc- Updated
- 2026-11-02
OSV
5.3
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long data fields such as multiple concatenated email addresses. NOTE: the PostSRSd maintainer acknowledges "theoretically, this error should never occur ... I'm not sure if there's a reliable way to trigger this condition by an external attacker, but it is a security bug in PostSRSd nevertheless."
- Record
CVE-2021-35525- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-35525
5.3
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long data fields such as multiple concatenated email addresses. NOTE: the PostSRSd maintainer acknowledges "theoretically, this error should never occur ... I'm not sure if there's a reliable way to trigger this condition by an external attacker, but it is a security bug in PostSRSd nevertheless."
- Record
DEBIAN-CVE-2021-35525- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-35525
5.3
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long data fields such as multiple concatenated email addresses. NOTE: the PostSRSd maintainer acknowledges "theoretically, this error should never occur ... I'm not sure if there's a reliable way to trigger this condition by an external attacker, but it is a security bug in PostSRSd nevertheless."
- Record
UBUNTU-CVE-2021-35525- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
postsrsdDebian:12 |
before 1.10-2 | 1.10-2 |
postsrsdDebian:13 |
before 1.10-2 | 1.10-2 |
postsrsdDebian:14 |
before 1.10-2 | 1.10-2 |
postsrsdUbuntu:16.04:LTS |
All versions, plus listed versions 1.2-1 |
None known |
postsrsdUbuntu:18.04:LTS |
All versions, plus listed versions 1.4-11.4-1ubuntu0.1 |
None known |
postsrsdUbuntu:20.04:LTS |
All versions, plus listed versions 1.5-2 |
None known |
postsrsdUbuntu:22.04:LTS |
All versions, plus listed versions 1.10-2 |
None known |
postsrsdUbuntu:24.04:LTS |
All versions, plus listed versions 1.10-21.10-2.1build1 |
None known |
postsrsdUbuntu:25.10 |
All versions, plus listed versions 1.10-2.2 |
None known |
postsrsdUbuntu:26.04:LTS |
All versions, plus listed versions 1.10-2.22.0.11-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-35525 is a medium vulnerability (CVSS 5.3) in Postsrsd Project Postsrsd, published June 28, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.65%, the 76th percentile. Fixed in postsrsd 1.10-2.
References
github.com/roehling/postsrsd/releases/tag/1.11
github.com/roehling/postsrsd/commit/077be98d8c8a9847e4ae0c7dc09e7474cbe27db2
bugs.gentoo.org/793674
security.gentoo.org/glsa/202107-08
nvd.nist.gov/vuln/detail/CVE-2021-35525
github.com/advisories/GHSA-w799-rf9r-4rqc
security-tracker.debian.org/tracker/CVE-2021-35525
ubuntu.com/security/CVE-2021-35525
cve.org/CVERecord?id=CVE-2021-35525