CVE-2021-35955
Cross site scripting via HTML attributes in the back end
Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.8
Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.
- Record
CVE-2021-35955- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.
- Record
CVE-2021-35955- Updated
- 2026-11-02
EUVDEUVD-2021-1756 No score
Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.
- Record
EUVD-2021-1756- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hr3h-x6gq-rqcp
5.9
Cross site scripting via HTML attributes in the back end
Impact
It is possible for untrusted users to inject malicious code into HTML attributes in the back end, which will be executed both in the element preview (back end) and on the website (front end).
Installations are only affected if there are untrusted back end users who have the rights to modify HTML fields (e.g. TinyMCE).
Patches
Update to Contao 4.4.56, 4.9.18 or 4.11.7
Workarounds
Disable all fields that allow HTML for untrusted back end users or disable the login for these users.
References
https://contao.org/en/security-advisories/cross-site-scripting-via-html-attributes-in-the-back-end
For more information
If you have any questions or comments about this advisory, open an issue in contao/contao.
Credits
Thanks to Mikhail Khramenkov and Moritz Vondano for reporting this security issue.
- Record
GHSA-hr3h-x6gq-rqcp- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
4.8
Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.
- Record
CVE-2021-35955- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-hr3h-x6gq-rqcp
5.9
Cross site scripting via HTML attributes in the back end
Impact
It is possible for untrusted users to inject malicious code into HTML attributes in the back end, which will be executed both in the element preview (back end) and on the website (front end).
Installations are only affected if there are untrusted back end users who have the rights to modify HTML fields (e.g. TinyMCE).
Patches
Update to Contao 4.4.56, 4.9.18 or 4.11.7
Workarounds
Disable all fields that allow HTML for untrusted back end users or disable the login for these users.
References
https://contao.org/en/security-advisories/cross-site-scripting-via-html-attributes-in-the-back-end
For more information
If you have any questions or comments about this advisory, open an issue in contao/contao.
Credits
Thanks to Mikhail Khramenkov and Moritz Vondano for reporting this security issue.
- Record
GHSA-hr3h-x6gq-rqcp- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
contao/core-bundlePackagist |
4.0.0 up to 4.4.56 | 4.4.56 |
contao/contaoPackagist |
4.0.0 up to 4.4.56 | 4.4.56 |
contao/contaoPackagist |
4.5.0 up to 4.9.18 | 4.9.18 |
contao/contaoPackagist |
4.10.0 up to 4.11.7 | 4.11.7 |
contao/core-bundlePackagist |
4.5.0 up to 4.9.18 | 4.9.18 |
contao/core-bundlePackagist |
4.10.0 up to 4.11.7 | 4.11.7 |
contao/core-bundlePackagist |
4.0.0 up to 4.4.56, plus listed versions 4.0.14.0.24.0.34.0.44.1.0 Show 45 moreShow less4.1.0-RC14.1.0-beta14.1.14.1.24.1.34.2.04.2.0-RC14.2.0-beta14.2.14.2.24.2.34.2.44.2.54.3.04.3.0-RC14.3.14.3.104.3.114.3.24.3.34.3.44.3.54.3.64.3.74.3.84.3.94.4.04.4.0-RC14.4.0-RC24.4.0-beta14.4.14.4.104.4.114.4.124.4.134.4.144.4.154.4.164.4.174.4.184.4.194.4.24.4.204.4.214.4.22 |
4.4.56 |
contao/contaoPackagist |
4.0.0 up to 4.4.56, plus listed versions 4.4.224.4.234.4.244.4.254.4.26 Show 29 moreShow less4.4.274.4.284.4.294.4.304.4.314.4.324.4.334.4.344.4.354.4.364.4.374.4.384.4.394.4.404.4.414.4.424.4.434.4.444.4.454.4.464.4.474.4.484.4.494.4.504.4.514.4.524.4.534.4.544.4.55 |
4.4.56 |
contao/contaoPackagist |
4.5.0 up to 4.9.18, plus listed versions 4.5.134.5.144.6.04.6.14.6.10 Show 45 moreShow less4.6.114.6.124.6.134.6.144.6.24.6.34.6.44.6.54.6.64.6.74.6.84.6.94.7.04.7.0-RC14.7.0-RC24.7.0-RC34.7.0-RC44.7.14.7.24.7.34.7.44.7.54.7.64.7.74.8.04.8.0-RC14.8.0-RC24.8.14.8.24.8.34.8.44.8.54.8.64.8.74.8.84.9.04.9.0-RC14.9.0-RC24.9.14.9.104.9.114.9.124.9.134.9.144.9.15 |
4.9.18 |
contao/contaoPackagist |
4.10.0 up to 4.11.7, plus listed versions 4.10.14.10.24.10.34.10.44.10.5 Show 11 moreShow less4.10.64.10.74.11.04.11.0-RC14.11.0-RC24.11.14.11.24.11.34.11.44.11.54.11.6 |
4.11.7 |
contao/core-bundlePackagist |
4.5.0 up to 4.9.18, plus listed versions 4.5.14.5.104.5.114.5.124.5.13 Show 45 moreShow less4.5.144.5.24.5.34.5.44.5.54.5.64.5.74.5.84.5.94.6.04.6.0-RC14.6.0-RC24.6.0-RC34.6.14.6.104.6.114.6.124.6.134.6.144.6.24.6.34.6.44.6.54.6.64.6.74.6.84.6.94.7.04.7.0-RC14.7.0-RC24.7.0-RC34.7.0-RC44.7.14.7.24.7.34.7.44.7.54.7.64.7.74.8.04.8.0-RC14.8.0-RC24.8.14.8.24.8.3 |
4.9.18 |
contao/core-bundlePackagist |
4.10.0 up to 4.11.7, plus listed versions 4.10.14.10.24.10.34.10.44.10.5 Show 11 moreShow less4.10.64.10.74.11.04.11.0-RC14.11.0-RC24.11.14.11.24.11.34.11.44.11.54.11.6 |
4.11.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-35955 is a medium vulnerability (CVSS 4.8) in Contao, published August 12, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.56%, the 46th percentile. Fixed in contao/core-bundle 4.4.56.
References
contao.org/en/news/contao-4-9-16-and-4-11-5-are-available.html
github.com/contao/contao/security/advisories/GHSA-hr3h-x6gq-rqcp
nvd.nist.gov/vuln/detail/CVE-2021-35955
contao.org/en/security-advisories/cross-site-scripting-via-html-attributes-in-the-back-end.html
github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2021-35955.yaml
github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2021-35955.yaml
github.com/advisories/GHSA-hr3h-x6gq-rqcp
github.com/contao/contao
Left out here: 75 versions. The JSON record has them.