CVE-2021-36057
XMP Toolkit SDK Write-What-Where Condition Could Lead To Local Application Denial Of Service
XMP Toolkit SDK version 2020.1 (and earlier) is affected by a write-what-where condition vulnerability caused during the application's memory allocation process. This may cause the memory management functions to become mismatched resulting in local application denial of service in the context of the current user.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
4.0
XMP Toolkit SDK Write-What-Where Condition Could Lead To Local Application Denial Of Service
XMP Toolkit SDK version 2020.1 (and earlier) is affected by a write-what-where condition vulnerability caused during the application's memory allocation process. This may cause the memory management functions to become mismatched resulting in local application denial of service in the context of the current user.
- Record
CVE-2021-36057- CVSS 3.0
- 4.0 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-123
- Updated
- 2026-11-02
EUVDEUVD-2021-22690
4.0
XMP Toolkit SDK version 2020.1 (and earlier) is affected by a write-what-where condition vulnerability caused during the application's memory allocation process. This may cause the memory management functions to become mismatched resulting in local application denial of service in the context of the current user.
- Record
EUVD-2021-22690- CVSS 3.0
- 4.0 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-426g-wxf4-8rhw
4.0
XMP Toolkit SDK version 2020.1 (and earlier) is affected by a write-what-where condition...
XMP Toolkit SDK version 2020.1 (and earlier) is affected by a write-what-where condition vulnerability caused during the application's memory allocation process. This may cause the memory management functions to become mismatched resulting in local application denial of service in the context of the current user.
- Record
GHSA-426g-wxf4-8rhw- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-123
- Updated
- 2026-11-02
NVD
3.3
XMP Toolkit SDK version 2020.1 (and earlier) is affected by a write-what-where condition vulnerability caused during the application's memory allocation process. This may cause the memory management functions to become mismatched resulting in local application denial of service in the context of the current user.
- Record
CVE-2021-36057- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - CVSS 3.0
- 4.0 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 2.0
- 2.1 Low
AV:L/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-123
- Updated
- 2026-11-02
OSV
3.3
XMP Toolkit SDK version 2020.1 (and earlier) is affected by a write-what-where condition vulnerability caused during the application's memory allocation process. This may cause the memory management functions to become mismatched resulting in local application denial of service in the context of the current user.
- Record
CVE-2021-36057- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-36057
3.3
XMP Toolkit SDK version 2020.1 (and earlier) is affected by a write-what-where condition vulnerability caused during the application's memory allocation process. This may cause the memory management functions to become mismatched resulting in local application denial of service in the context of the current user.
- Record
DEBIAN-CVE-2021-36057- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-36057
3.3
XMP Toolkit SDK version 2020.1 (and earlier) is affected by a write-what-where condition vulnerability caused during the application's memory allocation process. This may cause the memory management functions to become mismatched resulting in local application denial of service in the context of the current user.
- Record
UBUNTU-CVE-2021-36057- CVSS 3.1
- 3.3 Low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L - CVSS 3.0
- 4.0 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
exempiDebian:12 |
before 2.6.0-1 | 2.6.0-1 |
exempiDebian:13 |
before 2.6.0-1 | 2.6.0-1 |
exempiDebian:14 |
before 2.6.0-1 | 2.6.0-1 |
exempiDebian:10 From an advisory covering 24 CVEs |
before 2.5.0-2+deb10u1, plus listed versions 2.5.0-2 |
2.5.0-2+deb10u1 |
exempiDebian:11 From an advisory covering 22 CVEs |
before 2.5.2-1+deb11u1, plus listed versions 2.5.2-1 |
2.5.2-1+deb11u1 |
exempiUbuntu:16.04:LTS |
All versions, plus listed versions 2.2.2-22.2.2-2ubuntu0.1 |
None known |
exempiUbuntu:18.04:LTS |
before 2.4.5-2ubuntu0.1, plus listed versions 2.4.3-1ubuntu12.4.5-2 |
2.4.5-2ubuntu0.1 |
exempiUbuntu:20.04:LTS |
before 2.5.1-1ubuntu0.1, plus listed versions 2.5.1-12.5.1-1build1 |
2.5.1-1ubuntu0.1 |
exempiUbuntu:22.04:LTS |
before 2.5.2-1ubuntu0.22.04.1, plus listed versions 2.5.2-1build1 |
2.5.2-1ubuntu0.22.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-36057 is a medium vulnerability (CVSS 4.0) in Adobe Xmp Toolkit, published September 1, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.62%, the 49th percentile. Fixed in exempi 2.6.0-1.
References
helpx.adobe.com/security/products/xmpcore/apsb21-65.html
lists.debian.org/debian-lts-announce/2023/09/msg00032.html
lists.debian.org/debian-lts-announce/2025/08/msg00003.html
nvd.nist.gov/vuln/detail/CVE-2021-36057
github.com/advisories/GHSA-426g-wxf4-8rhw
security-tracker.debian.org/tracker/CVE-2021-36057
ubuntu.com/security/CVE-2021-36057
gitlab.freedesktop.org/libopenraw/exempi/-/releases
cve.org/CVERecord?id=CVE-2021-36057