Every CVE Search/ Get API key

CVE-2021-36152

Insecure TrustManager used in LDAP connections

9.8 CriticalFix available

Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions <= 0.15.0. Users should update to version 0.16.0 which addresses this issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.30%Up 0.4 points since Feb 8, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions <= 0.15.0. Users should update to version 0.16.0 which addresses this issue.

Record
CVE-2021-36152
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Insecure TrustManager used in LDAP connections

Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions <= 0.15.0. Users should update to version 0.16.0 which addresses this issue.

Record
CVE-2021-36152
Updated
2026-11-02
EUVDEUVD-2022-1145 No score

Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions <= 0.15.0. Users should update to version 0.16.0 which addresses this issue.

Record
EUVD-2022-1145
Updated
2026-11-03
GitHub AdvisoriesGHSA-q5rx-8c2h-5q7j 9.8

Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service

Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions <= 0.15.0. Users should update to version 0.16.0 which addresses this issue.

Record
GHSA-q5rx-8c2h-5q7j
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-q5rx-8c2h-5q7j 9.8

Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service

Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions <= 0.15.0. Users should update to version 0.16.0 which addresses this issue.

Record
GHSA-q5rx-8c2h-5q7j
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.gobblin:gobblin-core
Maven
before 0.16.0
0.16.0
org.apache.gobblin:gobblin-core
Maven
before 0.16.0, plus listed versions
0.12.00.13.00.14.00.15.0
0.16.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-36152 is a critical vulnerability (CVSS 9.8) in Apache Gobblin, published February 4, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.30%, the 70th percentile. Fixed in org.apache.gobblin:gobblin-core 0.16.0.

References

MoveEnter Open