Every CVE Search/ Get API key

CVE-2021-36409

There is an Assertion `scaling_list_pred_matrix_id_delta==1' failed at sps.cc:925 in libde265 v1...

7.8 HighFix available

There is an Assertion `scaling_list_pred_matrix_id_delta==1' failed at sps.cc:925 in libde265 v1.0.8 when decoding file, which allows attackers to cause a Denial of Service (DoS) by running the application with a crafted file or possibly have unspecified other impact.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.97%Up 0.4 points since Jan 11, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

There is an Assertion `scaling_list_pred_matrix_id_delta==1' failed at sps.cc:925 in libde265 v1.0.8 when decoding file, which allows attackers to cause a Denial of Service (DoS) by running the application with a crafted file or possibly have unspecified other impact.

Record
CVE-2021-36409
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-617
Updated
2026-11-02
CVE List No score

There is an Assertion `scaling_list_pred_matrix_id_delta==1' failed at sps.cc:925 in libde265 v1.0.8 when decoding file, which allows attackers to cause a Denial of Service (DoS) by running the application with a crafted file or possibly have unspecified other impact.

Record
CVE-2021-36409
Updated
2026-11-02
EUVDEUVD-2021-23012 No score

There is an Assertion `scaling_list_pred_matrix_id_delta==1' failed at sps.cc:925 in libde265 v1.0.8 when decoding file, which allows attackers to cause a Denial of Service (DoS) by running the application with a crafted file or possibly have unspecified other impact.

Record
EUVD-2021-23012
Updated
2026-11-03
GitHub AdvisoriesGHSA-wgpj-6x6j-fh7r 7.8

There is an Assertion `scaling_list_pred_matrix_id_delta==1' failed at sps.cc:925 in libde265 v1...

There is an Assertion `scaling_list_pred_matrix_id_delta==1' failed at sps.cc:925 in libde265 v1.0.8 when decoding file, which allows attackers to cause a Denial of Service (DoS) by running the application with a crafted file or possibly have unspecified other impact.

Record
GHSA-wgpj-6x6j-fh7r
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-617
Updated
2026-11-02
OSV 7.8

There is an Assertion `scaling_list_pred_matrix_id_delta==1' failed at sps.cc:925 in libde265 v1.0.8 when decoding file, which allows attackers to cause a Denial of Service (DoS) by running the application with a crafted file or possibly have unspecified other impact.

Record
CVE-2021-36409
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-36409 7.8

There is an Assertion `scaling_list_pred_matrix_id_delta==1' failed at sps.cc:925 in libde265 v1.0.8 when decoding file, which allows attackers to cause a Denial of Service (DoS) by running the application with a crafted file or possibly have unspecified other impact.

Record
DEBIAN-CVE-2021-36409
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-36409 7.8

There is an Assertion `scaling_list_pred_matrix_id_delta==1' failed at sps.cc:925 in libde265 v1.0.8 when decoding file, which allows attackers to cause a Denial of Service (DoS) by running the application with a crafted file or possibly have unspecified other impact.

Record
UBUNTU-CVE-2021-36409
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2023-0093 No score

Updated libde265 packages fix security vulnerability

libde265 has been updated to version 1.0.11 to fix many security issues.

Record
MGASA-2023-0093
Updated
2026-11-02
OSVUSN-6627-1 No score

libde265 vulnerabilities

It was discovered that libde265 could be made to read out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. (CVE-2021-35452, CVE-2021-36411, CVE-2022-43238, CVE-2022-43241, CVE-2022-43242)

It was discovered that libde265 did not properly manage memory. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. (CVE-2021-36408)

It was discovered that libde265 contained a logical error. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. (CVE-2021-36409)

It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2021-36410, CVE-2022-43235, CVE-2022-43236, CVE-2022-43237, CVE-2022-43239, CVE-2022-43240, CVE-2022-43243, CVE-2022-43248, CVE-2022-43252, CVE-2022-43253)

It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-1253)

Record
USN-6627-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libde265
Debian:12
before 1.0.8-1.1
1.0.8-1.1
libde265
Debian:13
before 1.0.8-1.1
1.0.8-1.1
libde265
Debian:14
before 1.0.8-1.1
1.0.8-1.1
libde265
Debian:10
From an advisory covering 16 CVEs
before 1.0.3-1+deb10u1, plus listed versions
1.0.3-1
1.0.3-1+deb10u1
libde265
Debian:11
From an advisory covering 46 CVEs
before 1.0.11-0+deb11u1, plus listed versions
1.0.8-11.0.8-1.11.0.9-11.0.9-1.1
1.0.11-0+deb11u1
libde265
Mageia:8
From an advisory covering 46 CVEs
before 1.0.11-1.mga8
1.0.11-1.mga8
libde265
Mageia:8
From an advisory covering 46 CVEs
before 1.0.11-1.mga8.tainted
1.0.11-1.mga8.tainted
libde265
Ubuntu:Pro:16.04:LTS
before 1.0.2-2ubuntu0.16.04.1~esm2, plus listed versions
1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm1
1.0.2-2ubuntu0.16.04.1~esm2
libde265
Ubuntu:Pro:18.04:LTS
before 1.0.2-2ubuntu0.18.04.1~esm2, plus listed versions
1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm1
1.0.2-2ubuntu0.18.04.1~esm2
libde265
Ubuntu:20.04:LTS
before 1.0.4-1ubuntu0.2, plus listed versions
1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.1
1.0.4-1ubuntu0.2
Show 5 moreShow less
Affected packages
PackageAffectedFixed
libde265
Ubuntu:22.04:LTS
before 1.0.8-1ubuntu0.1, plus listed versions
1.0.8-1
1.0.8-1ubuntu0.1
libde265
Ubuntu:Pro:16.04:LTS
From an advisory covering 18 CVEs
before 1.0.2-2ubuntu0.16.04.1~esm2, plus listed versions
1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm1
1.0.2-2ubuntu0.16.04.1~esm2
libde265
Ubuntu:Pro:18.04:LTS
From an advisory covering 18 CVEs
before 1.0.2-2ubuntu0.18.04.1~esm2, plus listed versions
1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm1
1.0.2-2ubuntu0.18.04.1~esm2
libde265
Ubuntu:20.04:LTS
From an advisory covering 18 CVEs
before 1.0.4-1ubuntu0.2, plus listed versions
1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.1
1.0.4-1ubuntu0.2
libde265
Ubuntu:22.04:LTS
From an advisory covering 18 CVEs
before 1.0.8-1ubuntu0.1, plus listed versions
1.0.8-1
1.0.8-1ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-36409 is a high vulnerability (CVSS 7.8) in Struktur Libde265, published January 10, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.97%, the 61st percentile. Fixed in libde265 1.0.8-1.1.

References

Show 25 moreShow less
MoveEnter Open