Every CVE Search/ Get API key

CVE-2021-3663

Improper Restriction of Excessive Authentication Attempts in firefly-iii/firefly-iii

5.3 MediumFix available

firefly-iii is vulnerable to Improper Restriction of Excessive Authentication Attempts

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.71%Up 0.1 points since Jul 26, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.3

Improper Restriction of Excessive Authentication Attempts in firefly-iii/firefly-iii

firefly-iii is vulnerable to Improper Restriction of Excessive Authentication Attempts

Record
CVE-2021-3663
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-307
Updated
2026-11-02
EUVDEUVD-2021-1572 5.3

firefly-iii is vulnerable to Improper Restriction of Excessive Authentication Attempts

Record
EUVD-2021-1572
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-56cx-wf47-hx7w 5.3

No Restriction of Excessive Authentication Attempts in Firefly III

firefly-iii is vulnerable to Improper Lack of Restriction of Excessive Authentication Attempts

Record
GHSA-56cx-wf47-hx7w
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-307
Updated
2026-11-02
NVD 7.5

firefly-iii is vulnerable to Improper Restriction of Excessive Authentication Attempts

Record
CVE-2021-3663
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-307
Updated
2026-11-02
OSV 7.5

firefly-iii is vulnerable to Improper Restriction of Excessive Authentication Attempts

Record
CVE-2021-3663
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-56cx-wf47-hx7w 5.3

No Restriction of Excessive Authentication Attempts in Firefly III

firefly-iii is vulnerable to Improper Lack of Restriction of Excessive Authentication Attempts

Record
GHSA-56cx-wf47-hx7w
CVSS 3.0
5.3 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-307
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
grumpydictator/firefly-iii
Packagist
before 5.5.13
5.5.13
grumpydictator/firefly-iii
Packagist
before 5.5.13, plus listed versions
3.0.03.0.13.0.23.0.33.1
Show 45 moreShow less
3.1.13.1.23.1.33.1.43.1.53.1.63.103.10.13.10.23.10.33.10.43.2.03.2.13.2.23.2.33.2.43.2.53.33.3.13.3.23.3.33.3.43.3.53.3.63.3.73.3.83.3.93.43.4.0.13.4.0.103.4.0.23.4.0.33.4.0.43.4.0.53.4.0.63.4.0.73.4.0.83.4.0.93.4.13.4.103.4.113.4.23.4.33.4.43.4.4.1
5.5.13

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-3663 is a medium vulnerability (CVSS 5.3) in Firefly-iii Firefly-iii/firefly-iii, published July 25, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.71%, the 53rd percentile. Fixed in grumpydictator/firefly-iii 5.5.13.

References

This page doesn't list everything

Left out here: 193 versions. The JSON record has them.

MoveEnter Open