CVE-2021-36773
uBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter...
uBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter nesting for strict blocking, which allows crafted web sites to cause a denial of service (unbounded recursion that can trigger memory consumption and a loss of all blocking functionality).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
uBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter nesting for strict blocking, which allows crafted web sites to cause a denial of service (unbounded recursion that can trigger memory consumption and a loss of all blocking functionality).
- Record
CVE-2021-36773- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-674
- Updated
- 2026-11-02
CVE List No score
uBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter nesting for strict blocking, which allows crafted web sites to cause a denial of service (unbounded recursion that can trigger memory consumption and a loss of all blocking functionality).
- Record
CVE-2021-36773- Updated
- 2026-11-02
EUVDEUVD-2021-23361 No score
uBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter nesting for strict blocking, which allows crafted web sites to cause a denial of service (unbounded recursion that can trigger memory consumption and a loss of all blocking functionality).
- Record
EUVD-2021-23361- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vgm6-c9jx-rm2c
7.5
uBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter...
uBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter nesting for strict blocking, which allows crafted web sites to cause a denial of service (unbounded recursion that can trigger memory consumption and a loss of all blocking functionality).
- Record
GHSA-vgm6-c9jx-rm2c- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-674
- Updated
- 2026-11-02
OSV
7.5
uBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter nesting for strict blocking, which allows crafted web sites to cause a denial of service (unbounded recursion that can trigger memory consumption and a loss of all blocking functionality).
- Record
CVE-2021-36773- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-36773
7.5
uBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter nesting for strict blocking, which allows crafted web sites to cause a denial of service (unbounded recursion that can trigger memory consumption and a loss of all blocking functionality).
- Record
DEBIAN-CVE-2021-36773- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-36773
7.5
uBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter nesting for strict blocking, which allows crafted web sites to cause a denial of service (unbounded recursion that can trigger memory consumption and a loss of all blocking functionality).
- Record
UBUNTU-CVE-2021-36773- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ublock-originDebian:12 |
before 1.37.0+dfsg-1 | 1.37.0+dfsg-1 |
ublock-originDebian:13 |
before 1.37.0+dfsg-1 | 1.37.0+dfsg-1 |
ublock-originDebian:14 |
before 1.37.0+dfsg-1 | 1.37.0+dfsg-1 |
ublock-originDebian:9 |
before 1.42.0+dfsg-1~deb9u1, plus listed versions 1.10.4+dfsg-11.11.4+dfsg-11.11.4+dfsg-21.12.4+dfsg-11.13.6+dfsg-1 Show 35 moreShow less1.13.8+dfsg-11.16.14+dfsg-11.16.14+dfsg-1~deb9u11.16.14+dfsg-21.16.14+dfsg-2~deb9u11.16.6+dfsg-11.16.6+dfsg-1.11.17.0+dfsg-11.17.0+dfsg-21.17.0+dfsg-31.18.10+dfsg-11.18.2+dfsg-11.18.2+dfsg-21.18.4+dfsg-11.18.4+dfsg-21.19.0+dfsg-11.19.0+dfsg-21.22.2+dfsg-11.22.2+dfsg-1~deb10u11.22.2+dfsg-1~deb9u11.22.2+dfsg-21.25.0+dfsg-11.28.0+dfsg-11.29.0+dfsg-11.29.0+dfsg-21.30.0+dfsg-11.30.0+dfsg-1~deb10u11.32.0+dfsg-11.33.0+dfsg-11.37.0+dfsg-11.37.0+dfsg-1~deb10u11.37.0+dfsg-1~deb11u11.39.0+dfsg-11.39.0+dfsg-21.40.2+dfsg-1 |
1.42.0+dfsg-1~deb9u1 |
ublock-originUbuntu:16.04:LTS |
All versions, plus listed versions 1.5.6+dfsg-11.6.0+dfsg-11.6.6+dfsg-1 |
None known |
ublock-originUbuntu:18.04:LTS |
All versions, plus listed versions 1.13.8+dfsg-1 |
None known |
ublock-originUbuntu:20.04:LTS |
All versions, plus listed versions 1.19.0+dfsg-21.22.2+dfsg-1 |
None known |
umatrixUbuntu:20.04:LTS |
All versions, plus listed versions 1.3.16+dfsg-2 |
None known |
ublock-originUbuntu:22.04:LTS |
All versions, plus listed versions 1.33.0+dfsg-1build11.37.0+dfsg-11.39.0+dfsg-21.40.2+dfsg-1 |
None known |
umatrixUbuntu:22.04:LTS |
All versions, plus listed versions 1.4.0+dfsg-1 |
None known |
ublock-originUbuntu:24.04:LTS |
All versions, plus listed versions 1.51.0+dfsg-21.52.0+dfsg-11.53.3rc0+dfsg-11.54.0+dfsg-11.55.0+dfsg-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-36773 is a high vulnerability (CVSS 7.5) in Sciruby Nmatrix, published July 18, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.26%, the 69th percentile. Fixed in ublock-origin 1.37.0+dfsg-1.
References
news.ycombinator.com/item?id=27833752
github.com/vtriolet/writings/blob/main/posts/2021/ublock_origin_and_umatrix_denial_of_service.adoc
lists.debian.org/debian-lts-announce/2022/06/msg00024.html
nvd.nist.gov/vuln/detail/CVE-2021-36773
github.com/advisories/GHSA-vgm6-c9jx-rm2c
security-tracker.debian.org/tracker/CVE-2021-36773
ubuntu.com/security/CVE-2021-36773
cve.org/CVERecord?id=CVE-2021-36773