CVE-2021-37519
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of...
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.
- Record
CVE-2021-37519- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List
5.5
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.
- Record
CVE-2021-37519- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
EUVDEUVD-2021-24081
5.5
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.
- Record
EUVD-2021-24081- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-5pff-p34f-mm94
5.5
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of...
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.
- Record
GHSA-5pff-p34f-mm94- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
5.5
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.
- Record
CVE-2021-37519- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-37519
5.5
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.
- Record
DEBIAN-CVE-2021-37519- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-37519
5.5
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.
- Record
UBUNTU-CVE-2021-37519- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVBIT-memcached-2021-37519 No score
Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.
- Record
BIT-memcached-2021-37519- Updated
- 2026-11-02
OSVCLSA-2026-1779095842 No score
memcached: Fix of CVE-2021-37519
- CVE-2021-37519: heap buffer overflow in authfile_load() when the auth file lacks a trailing newline; missing bounds check on fgets() and missing NUL check in the user-entry parse loop allow local DoS via a crafted --auth-file.
- Record
CLSA-2026-1779095842- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
memcachedBitnami |
before 1.6.10 | 1.6.10 |
memcachedTuxCare:AlmaLinux:9.2 |
before 1.6.9-7.el9.tuxcare.els1 | 1.6.9-7.el9.tuxcare.els1 |
memcached-develTuxCare:AlmaLinux:9.2 |
before 1.6.9-7.el9.tuxcare.els1 | 1.6.9-7.el9.tuxcare.els1 |
memcached-selinuxTuxCare:AlmaLinux:9.2 |
before 1.6.9-7.el9.tuxcare.els1 | 1.6.9-7.el9.tuxcare.els1 |
memcachedDebian:12 |
before 1.6.10+dfsg-1 | 1.6.10+dfsg-1 |
memcachedDebian:13 |
before 1.6.10+dfsg-1 | 1.6.10+dfsg-1 |
memcachedDebian:14 |
before 1.6.10+dfsg-1 | 1.6.10+dfsg-1 |
memcachedUbuntu:20.04:LTS |
All versions, plus listed versions 1.5.10-0ubuntu31.5.10-0ubuntu41.5.19-21.5.20-11.5.22-1ubuntu1 Show 4 moreShow less1.5.22-21.5.22-2ubuntu0.11.5.22-2ubuntu0.21.5.22-2ubuntu0.3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-37519 is a medium vulnerability (CVSS 5.5) in Memcached, published February 3, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 30th percentile. Fixed in memcached 1.6.10.
References
github.com/memcached/memcached/issues/805
github.com/memcached/memcached/pull/806/commits/264722ae4e248b453be00e97197dadc685b60fd0
nvd.nist.gov/vuln/detail/CVE-2021-37519
github.com/advisories/GHSA-5pff-p34f-mm94
github.com/memcached/memcached/commit/ddee3e27a031be22f5f28c160be18fd3cb9bc63d
errata.tuxcare.com/els_os/almalinux9.2esu/CLSA-2026-1779095842.html
security-tracker.debian.org/tracker/CVE-2021-37519
ubuntu.com/security/CVE-2021-37519
cve.org/CVERecord?id=CVE-2021-37519