Every CVE Search/ Get API key

CVE-2021-3756

Heap-based Buffer Overflow in hoene/libmysofa

6.2 MediumFix available

libmysofa is vulnerable to Heap-based Buffer Overflow

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
High

Exploit likelihood

1.07%Up 0.4 points since Oct 30, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.2

Heap-based Buffer Overflow in hoene/libmysofa

libmysofa is vulnerable to Heap-based Buffer Overflow

Record
CVE-2021-3756
CVSS 3.0
6.2 MediumCVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
Weakness
CWE-122
Updated
2026-11-02
EUVDEUVD-2021-27030 6.2

libmysofa is vulnerable to Heap-based Buffer Overflow

Record
EUVD-2021-27030
CVSS 3.0
6.2 MediumCVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-ph84-4hmc-hhqm No score

libmysofa is vulnerable to Heap-based Buffer Overflow

libmysofa is vulnerable to Heap-based Buffer Overflow

Record
GHSA-ph84-4hmc-hhqm
Weakness
CWE-122, CWE-787
Updated
2026-11-02
NVD 9.8

libmysofa is vulnerable to Heap-based Buffer Overflow

Record
CVE-2021-3756
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
6.2 MediumCVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-122, CWE-787
Updated
2026-11-02
OSV 9.8

libmysofa is vulnerable to Heap-based Buffer Overflow

Record
CVE-2021-3756
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-3756 9.8

libmysofa is vulnerable to Heap-based Buffer Overflow

Record
DEBIAN-CVE-2021-3756
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2021-3756 9.8

libmysofa is vulnerable to Heap-based Buffer Overflow

Record
UBUNTU-CVE-2021-3756
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
6.2 MediumCVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:11673-1 No score

libmysofa-devel-1.2.1-1.1 on GA media

These are all security issues fixed in the libmysofa-devel-1.2.1-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11673-1
Updated
2026-11-02
OSVROOT-OS-DEBIAN-11-CVE-2021-3756 No score

CVE-2021-3756 in libmysofa - Patched by Root

Root has patched CVE-2021-3756 in the libmysofa package for Root:Debian:11. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-11-CVE-2021-3756
Updated
2026-11-02
OSVUSN-5184-1 No score

libmysofa vulnerability

It was discovered that libmysofa mishandled certain input. An attacker could use this vulnerability to cause a denial of service (crash).

Record
USN-5184-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libmysofa
Debian:12
before 1.2.1~dfsg0-1
1.2.1~dfsg0-1
libmysofa
Debian:13
before 1.2.1~dfsg0-1
1.2.1~dfsg0-1
libmysofa
Debian:14
before 1.2.1~dfsg0-1
1.2.1~dfsg0-1
libmysofa
Root:Debian:11
before 1.2~dfsg0-1.root.io.2
1.2~dfsg0-1.root.io.21.2~dfsg0-1.root.io.31.2~dfsg0-1.root.io.41.2~dfsg0-1.aikido.61.2~dfsg0-1.root.io.11.2~dfsg0-1.root.io.5
rootio-libmysofa
Root:Debian:11
before 1.2~dfsg0-1.root.io.2
1.2~dfsg0-1.root.io.21.2~dfsg0-1.root.io.31.2~dfsg0-1.root.io.41.2~dfsg0-1.aikido.61.2~dfsg0-1.root.io.11.2~dfsg0-1.root.io.5
libmysofa
Ubuntu:Pro:18.04:LTS
before 0.6~dfsg0-3+deb10u1ubuntu0.1~esm1, plus listed versions
0.6~dfsg0-10.6~dfsg0-20.6~dfsg0-2ubuntu0.18.04.10.6~dfsg0-3+deb10u1build1
0.6~dfsg0-3+deb10u1ubuntu0.1~esm1
libmysofa
Ubuntu:Pro:20.04:LTS
before 1.0~dfsg0-1ubuntu0.1~esm1, plus listed versions
0.7~dfsg0-10.8~dfsg0-10.9~dfsg0-10.9.1~dfsg0-11.0~dfsg0-1
1.0~dfsg0-1ubuntu0.1~esm1
libmysofa
Ubuntu:22.04:LTS
before 1.2.1~dfsg0-1, plus listed versions
1.2~dfsg0-1
1.2.1~dfsg0-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-3756 is a medium vulnerability (CVSS 6.2) in Hoene Hoene/libmysofa, published October 29, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.07%, the 65th percentile. Fixed in libmysofa 1.2.1~dfsg0-1.

References

Show 7 moreShow less
MoveEnter Open