Every CVE Search/ Get API key

CVE-2021-37627

Privilege escalation via form generator

8.0 HighFix available

Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.02%Up 0.4 points since Aug 12, 2021
90%50%10%1%

What each source reports

CVE List Score used 8.0

Privilege escalation via form generator

Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.

Record
CVE-2021-37627
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-269
Updated
2026-11-02
EUVDEUVD-2021-1752 8.0

Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.

Record
EUVD-2021-1752
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-hq5m-mqmx-fw6m 8.0

Privilege escalation via form generator

Impact

It is possible for untrusted users to gain administrator rights with the form generator.

Installations are only affected if there are untrusted back end users with access to the form generator.

Patches

Update to Contao 4.4.56, 4.9.18 or 4.11.7.

Workarounds

Disable the form generator or disable the login for untrusted back end users.

References

https://contao.org/en/security-advisories/privilege-escalation-with-the-form-generator

For more information

If you have any questions or comments about this advisory, open an issue in contao/contao.

Record
GHSA-hq5m-mqmx-fw6m
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-269
Updated
2026-11-02
NVD 8.0

Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.

Record
CVE-2021-37627
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-269
Updated
2026-11-02
OSV 7.2

Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.

Record
CVE-2021-37627
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-hq5m-mqmx-fw6m 8.0

Privilege escalation via form generator

Impact

It is possible for untrusted users to gain administrator rights with the form generator.

Installations are only affected if there are untrusted back end users with access to the form generator.

Patches

Update to Contao 4.4.56, 4.9.18 or 4.11.7.

Workarounds

Disable the form generator or disable the login for untrusted back end users.

References

https://contao.org/en/security-advisories/privilege-escalation-with-the-form-generator

For more information

If you have any questions or comments about this advisory, open an issue in contao/contao.

Record
GHSA-hq5m-mqmx-fw6m
CVSS 3.1
8.0 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-269
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
contao/core-bundle
Packagist
4.0.0 up to 4.4.56
4.4.56
contao/core-bundle
Packagist
4.5.0 up to 4.9.18
4.9.18
contao/core-bundle
Packagist
4.10.0 up to 4.11.7
4.11.7
contao/contao
Packagist
4.0.0 up to 4.4.56
4.4.56
contao/contao
Packagist
4.5.0 up to 4.9.18
4.9.18
contao/contao
Packagist
4.10.0 up to 4.11.7
4.11.7
contao/core-bundle
Packagist
4.0.0 up to 4.4.56, plus listed versions
4.0.14.0.24.0.34.0.44.1.0
Show 45 moreShow less
4.1.0-RC14.1.0-beta14.1.14.1.24.1.34.2.04.2.0-RC14.2.0-beta14.2.14.2.24.2.34.2.44.2.54.3.04.3.0-RC14.3.14.3.104.3.114.3.24.3.34.3.44.3.54.3.64.3.74.3.84.3.94.4.04.4.0-RC14.4.0-RC24.4.0-beta14.4.14.4.104.4.114.4.124.4.134.4.144.4.154.4.164.4.174.4.184.4.194.4.24.4.204.4.214.4.22
4.4.56
contao/core-bundle
Packagist
4.5.0 up to 4.9.18, plus listed versions
4.5.14.5.104.5.114.5.124.5.13
Show 45 moreShow less
4.5.144.5.24.5.34.5.44.5.54.5.64.5.74.5.84.5.94.6.04.6.0-RC14.6.0-RC24.6.0-RC34.6.14.6.104.6.114.6.124.6.134.6.144.6.24.6.34.6.44.6.54.6.64.6.74.6.84.6.94.7.04.7.0-RC14.7.0-RC24.7.0-RC34.7.0-RC44.7.14.7.24.7.34.7.44.7.54.7.64.7.74.8.04.8.0-RC14.8.0-RC24.8.14.8.24.8.3
4.9.18
contao/core-bundle
Packagist
4.10.0 up to 4.11.7, plus listed versions
4.10.14.10.24.10.34.10.44.10.5
Show 11 moreShow less
4.10.64.10.74.11.04.11.0-RC14.11.0-RC24.11.14.11.24.11.34.11.44.11.54.11.6
4.11.7
contao/contao
Packagist
4.0.0 up to 4.4.56, plus listed versions
4.4.224.4.234.4.244.4.254.4.26
Show 29 moreShow less
4.4.274.4.284.4.294.4.304.4.314.4.324.4.334.4.344.4.354.4.364.4.374.4.384.4.394.4.404.4.414.4.424.4.434.4.444.4.454.4.464.4.474.4.484.4.494.4.504.4.514.4.524.4.534.4.544.4.55
4.4.56
contao/contao
Packagist
4.5.0 up to 4.9.18, plus listed versions
4.5.134.5.144.6.04.6.14.6.10
Show 45 moreShow less
4.6.114.6.124.6.134.6.144.6.24.6.34.6.44.6.54.6.64.6.74.6.84.6.94.7.04.7.0-RC14.7.0-RC24.7.0-RC34.7.0-RC44.7.14.7.24.7.34.7.44.7.54.7.64.7.74.8.04.8.0-RC14.8.0-RC24.8.14.8.24.8.34.8.44.8.54.8.64.8.74.8.84.9.04.9.0-RC14.9.0-RC24.9.14.9.104.9.114.9.124.9.134.9.144.9.15
4.9.18
contao/contao
Packagist
4.10.0 up to 4.11.7, plus listed versions
4.10.14.10.24.10.34.10.44.10.5
Show 11 moreShow less
4.10.64.10.74.11.04.11.0-RC14.11.0-RC24.11.14.11.24.11.34.11.44.11.54.11.6
4.11.7

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-37627 is a high vulnerability (CVSS 8.0) in Contao, published August 11, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. Fixed in contao/core-bundle 4.4.56.

References

This page doesn't list everything

Left out here: 75 versions. The JSON record has them.

MoveEnter Open