CVE-2021-3765
Inefficient Regular Expression Complexity in validatorjs/validator.js
validator.js is vulnerable to Inefficient Regular Expression Complexity
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
5.3
Inefficient Regular Expression Complexity in validatorjs/validator.js
validator.js is vulnerable to Inefficient Regular Expression Complexity
- Record
CVE-2021-3765- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-1333
- Updated
- 2026-11-02
EUVDEUVD-2021-2382
5.3
validator.js is vulnerable to Inefficient Regular Expression Complexity
- Record
EUVD-2021-2382- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qgmg-gppg-76g5
5.3
Inefficient Regular Expression Complexity in validator.js
validator.js prior to 13.7.0 is vulnerable to Inefficient Regular Expression Complexity
- Record
GHSA-qgmg-gppg-76g5- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-1333
- Updated
- 2026-11-02
NVD
7.5
validator.js is vulnerable to Inefficient Regular Expression Complexity
- Record
CVE-2021-3765- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-1333
- Updated
- 2026-11-02
OSV
7.5
validator.js is vulnerable to Inefficient Regular Expression Complexity
- Record
CVE-2021-3765- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-qgmg-gppg-76g5
5.3
Inefficient Regular Expression Complexity in validator.js
validator.js prior to 13.7.0 is vulnerable to Inefficient Regular Expression Complexity
- Record
GHSA-qgmg-gppg-76g5- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-1333
- Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2021-3765
7.5
validator.js is vulnerable to Inefficient Regular Expression Complexity
- Record
UBUNTU-CVE-2021-3765- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVCLSA-2026-1777163882 No score
TuxCare security update for validator (2 CVEs)
TuxCare rebuilt validator to address 2 CVEs. Fixed in 10.11.0-tuxcare.3.
- Record
CLSA-2026-1777163882- Updated
- 2026-11-02
OSVCLSA-2026-1789162879 No score
TuxCare security update for validator (1 CVE)
TuxCare rebuilt validator to address 1 CVE. Fixed in 4.4.0-tuxcare.2.
- Record
CLSA-2026-1789162879- Updated
- 2026-11-02
OSVCLSA-2026-1790176084 No score
TuxCare security update for validator (1 CVE)
TuxCare rebuilt validator to address 1 CVE. Fixed in 7.2.0-tuxcare.2.
- Record
CLSA-2026-1790176084- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2021-3765 No score
CVE-2021-3765 in validator - Patched by Root
Root has patched CVE-2021-3765 in the validator package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2021-3765- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
validatornpm |
before 13.7.0 | 13.7.0 |
validatorTuxCare:npm From an advisory covering 2 CVEs |
10.11.0-tuxcare.0 up to 10.11.0-tuxcare.3, plus listed versions 10.11.010.11.0-tuxcare.110.11.0-tuxcare.2 |
10.11.0-tuxcare.3 |
validatorTuxCare:npm |
4.4.0-tuxcare.0 up to 4.4.0-tuxcare.2, plus listed versions 4.4.04.4.0-tuxcare.1 |
4.4.0-tuxcare.2 |
validatorTuxCare:npm |
7.2.0-tuxcare.0 up to 7.2.0-tuxcare.2, plus listed versions 7.2.07.2.0-tuxcare.1 |
7.2.0-tuxcare.2 |
validatorRoot:npm |
before 13.7.0-aikido.1 | 13.7.0-aikido.1 |
@rootio/validatorRoot:npm |
before 13.7.0-root.io.1 | 13.7.0-root.io.1 |
validator.jsUbuntu:16.04:LTS |
All versions, plus listed versions 3.17.0+dfsg1-14.7.1+dfsg1-1 |
None known |
validator.jsUbuntu:18.04:LTS |
All versions, plus listed versions 4.7.1+dfsg1-1.1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-3765 is a medium vulnerability (CVSS 5.3) in Validator Project Validator, published November 2, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.79%, the 78th percentile. Fixed in validator 13.7.0.
References
huntr.dev/bounties/c37e975c-21a3-4c5f-9b57-04d63b28cfc9
github.com/validatorjs/validator.js/commit/496fc8b2a7f5997acaaec33cc44d0b8dba5fb5e1
nvd.nist.gov/vuln/detail/CVE-2021-3765
github.com/advisories/GHSA-qgmg-gppg-76g5
github.com/validatorjs/validator.js
ubuntu.com/security/CVE-2021-3765
cve.org/CVERecord?id=CVE-2021-3765