CVE-2021-38084
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the...
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the-middle attackers can pipeline commands after the POP3 STLS command, injecting plaintext commands into an encrypted user session.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the-middle attackers can pipeline commands after the POP3 STLS command, injecting plaintext commands into an encrypted user session.
- Record
CVE-2021-38084- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-74
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the-middle attackers can pipeline commands after the POP3 STLS command, injecting plaintext commands into an encrypted user session.
- Record
CVE-2021-38084- Updated
- 2026-11-02
EUVDEUVD-2021-24557 No score
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the-middle attackers can pipeline commands after the POP3 STLS command, injecting plaintext commands into an encrypted user session.
- Record
EUVD-2021-24557- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m7r5-gh9x-xg9m No score
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the...
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the-middle attackers can pipeline commands after the POP3 STLS command, injecting plaintext commands into an encrypted user session.
- Record
GHSA-m7r5-gh9x-xg9m- Weakness
- CWE-74
- Updated
- 2026-11-02
OSV
8.1
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the-middle attackers can pipeline commands after the POP3 STLS command, injecting plaintext commands into an encrypted user session.
- Record
CVE-2021-38084- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-38084
8.1
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the-middle attackers can pipeline commands after the POP3 STLS command, injecting plaintext commands into an encrypted user session.
- Record
DEBIAN-CVE-2021-38084- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-38084
8.1
An issue was discovered in the POP3 component of Courier Mail Server before 1.1.5. Meddler-in-the-middle attackers can pipeline commands after the POP3 STLS command, injecting plaintext commands into an encrypted user session.
- Record
UBUNTU-CVE-2021-38084- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
courierDebian:12 |
All versions, plus listed versions 1.0.16-31.0.16-3.11.0.16-3.21.3.13-11.3.13-10 Show 30 moreShow less1.3.13-111.3.13-21.3.13-31.3.13-41.3.13-51.3.13-61.3.13-71.3.13-81.3.13-91.4.1-11.4.1-101.4.1-21.4.1-31.4.1-41.4.1-51.4.1-61.4.1-71.4.1-81.4.1-91.5.1-11.5.1-21.5.1-31.5.1-42.0.2-12.0.2-22.0.2-32.0.2-42.0.3-12.0.3-22.0.6-1 |
None known |
courierDebian:13 |
before 1.3.13-1 | 1.3.13-1 |
courierDebian:14 |
before 1.3.13-1 | 1.3.13-1 |
courierUbuntu:16.04:LTS |
All versions, plus listed versions 0.68.2-1ubuntu50.68.2-1ubuntu60.68.2-1ubuntu7 |
None known |
courierUbuntu:18.04:LTS |
All versions, plus listed versions 0.78.0-20.78.0-2ubuntu10.78.0-2ubuntu2 |
None known |
courierUbuntu:20.04:LTS |
All versions, plus listed versions 1.0.6-1build11.0.6-1build2 |
None known |
courierUbuntu:22.04:LTS |
All versions, plus listed versions 1.0.16-3build11.0.16-3build21.0.16-3build3 |
None known |
courierUbuntu:25.10 |
All versions, plus listed versions 1.3.13-111.4.1-11.4.1-21.4.1-2build11.4.1-3 |
None known |
courierUbuntu:26.10 |
All versions, plus listed versions 1.5.1-21.5.1-42.0.6-1 |
None known |
courierUbuntu:26.04:LTS |
All versions, plus listed versions 1.4.1-31.4.1-101.5.1-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-38084 is a high vulnerability (CVSS 8.1) in Courier-mta Courier Mail Server, published August 3, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.37%, the 72nd percentile. Fixed in courier 1.3.13-1.
References
sourceforge.net/p/courier/mailman/courier-imap/thread/cone.1382574216.483027.8082.1000%40monster.email-scan.com
sourceforge.net/p/courier/mailman/message/37329216
nvd.nist.gov/vuln/detail/CVE-2021-38084
github.com/advisories/GHSA-m7r5-gh9x-xg9m
security-tracker.debian.org/tracker/CVE-2021-38084
ubuntu.com/security/CVE-2021-38084
cve.org/CVERecord?id=CVE-2021-38084