CVE-2021-3878
Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp
corenlp is vulnerable to Improper Restriction of XML External Entity Reference
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp
corenlp is vulnerable to Improper Restriction of XML External Entity Reference
- Record
CVE-2021-3878- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-611
- Updated
- 2026-11-02
EUVDEUVD-2022-2592
9.8
corenlp is vulnerable to Improper Restriction of XML External Entity Reference
- Record
EUVD-2022-2592- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5h9g-8xcv-qjq9
9.8
Improper Restriction of XML External Entity Reference in Stanford CoreNLP
corenlp is vulnerable to Improper Restriction of XML External Entity Reference
- Record
GHSA-5h9g-8xcv-qjq9- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-611
- Updated
- 2026-11-02
NVD
9.8
corenlp is vulnerable to Improper Restriction of XML External Entity Reference
- Record
CVE-2021-3878- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-611
- Updated
- 2026-11-02
OSV
9.8
corenlp is vulnerable to Improper Restriction of XML External Entity Reference
- Record
CVE-2021-3878- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-5h9g-8xcv-qjq9
9.8
Improper Restriction of XML External Entity Reference in Stanford CoreNLP
corenlp is vulnerable to Improper Restriction of XML External Entity Reference
- Record
GHSA-5h9g-8xcv-qjq9- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-611
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
edu.stanford.nlp:stanford-corenlpMaven |
through 4.3.0 | 4.3.1 |
edu.stanford.nlp:stanford-corenlpMaven |
before 4.3.1, plus listed versions 1.2.01.3.01.3.11.3.21.3.3 Show 20 moreShow less1.3.41.3.53.2.03.3.03.3.13.43.4.13.5.03.5.13.5.23.6.03.7.03.8.03.9.13.9.24.0.04.2.04.2.14.2.24.3.0 |
4.3.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-3878 is a critical vulnerability (CVSS 9.8) in Stanford Corenlp, published October 15, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.89%, the 79th percentile. Fixed in edu.stanford.nlp:stanford-corenlp 4.3.1.