Every CVE Search/ Get API key

CVE-2021-3904

Cross-site Scripting (XSS) - Stored in getgrav/grav

6.3 MediumFix available

grav is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.59%Down 0.1 points since Oct 28, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.3

Cross-site Scripting (XSS) - Stored in getgrav/grav

grav is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Record
CVE-2021-3904
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2021-2302 6.3

grav is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Record
EUVD-2021-2302
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-5jxc-hmqf-3f73 6.3

Cross-Site Scripting in grav

grav prior to version 1.7.24 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').

Record
GHSA-5jxc-hmqf-3f73
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
NVD 5.4

grav is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Record
CVE-2021-3904
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

grav is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Record
CVE-2021-3904
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-5jxc-hmqf-3f73 6.3

Cross-Site Scripting in grav

grav prior to version 1.7.24 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').

Record
GHSA-5jxc-hmqf-3f73
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
getgrav/grav
Packagist
before 1.7.24
1.7.24
getgrav/grav
Packagist
before 1.7.24, plus listed versions
0.8.00.9.00.9.10.9.100.9.11
Show 45 moreShow less
0.9.120.9.130.9.140.9.150.9.160.9.170.9.180.9.190.9.20.9.200.9.210.9.220.9.230.9.240.9.250.9.260.9.270.9.280.9.290.9.30.9.300.9.310.9.320.9.330.9.340.9.350.9.360.9.370.9.380.9.390.9.40.9.400.9.410.9.420.9.430.9.440.9.450.9.50.9.60.9.70.9.80.9.91.0.01.0.0-rc.11.0.0-rc.2
1.7.24

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-3904 is a medium vulnerability (CVSS 6.3) in Getgrav Getgrav/grav, published October 27, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.59%, the 48th percentile. Fixed in getgrav/grav 1.7.24.

References

This page doesn't list everything

Left out here: 191 versions. The JSON record has them.

MoveEnter Open