CVE-2021-39177
User impersonation due to incorrect handling of the login JWT
Geyser is a bridge between Minecraft: Bedrock Edition and Minecraft: Java Edition. Versions of Geyser prior to 1.4.2-SNAPSHOT allow anyone that can connect to the server to forge a LoginPacket with manipulated JWT token allowing impersonation as any user. Version 1.4.2-SNAPSHOT contains a patch for the issue. There are no known workarounds aside from upgrading.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.4
User impersonation due to incorrect handling of the login JWT
Geyser is a bridge between Minecraft: Bedrock Edition and Minecraft: Java Edition. Versions of Geyser prior to 1.4.2-SNAPSHOT allow anyone that can connect to the server to forge a LoginPacket with manipulated JWT token allowing impersonation as any user. Version 1.4.2-SNAPSHOT contains a patch for the issue. There are no known workarounds aside from upgrading.
- Record
CVE-2021-39177- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-287
- Updated
- 2026-11-02
EUVDEUVD-2021-2067
7.4
Geyser is a bridge between Minecraft: Bedrock Edition and Minecraft: Java Edition. Versions of Geyser prior to 1.4.2-SNAPSHOT allow anyone that can connect to the server to forge a LoginPacket with manipulated JWT token allowing impersonation as any user. Version 1.4.2-SNAPSHOT contains a patch for the issue. There are no known workarounds aside from upgrading.
- Record
EUVD-2021-2067- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h77f-xxx7-4858
7.4
User impersonation due to incorrect handling of the login JWT
Impact
<!--_What kind of vulnerability is it? Who is impacted?_-->
This allows anyone that can connect to the server to forge a LoginPacket with manipulated JWT token allowing impersonation as any Bedrock user. Unless credentials are saved in your configuration, online mode is not affected as users are still required to log in separately. If your credentials are saved, there is no risk of exposing your email or password.
Patches
<!--_Has the problem been patched? What versions should users upgrade to?_-->
This was patched as part of https://github.com/GeyserMC/Geyser/commit/b9541505af68ac7b7c093206ac7b1ba88957a5a6 and https://github.com/GeyserMC/Geyser/commit/ab2f5b326fe590e09167e8b45b4b165ac06ecd13. if your Geyser version is 1.4.2-SNAPSHOT or later, the issue has been addressed on your build.
Workarounds
<!--_Is there a way for users to fix or remediate the vulnerability without upgrading?_-->
Geyser strongly recommends updating to fix this issue. If this isn't possible:
- Use online mode and don't save credentials in your Geyser configuration
- Use an additional authentication method on the Java server
References
<!--_Are there any links users can visit to find out more?_-->
This was disclosed to us by a staff member over at Hive; you can read their disclosure here: https://updates.playhive.com/changelog/weekend-maintenance-breakdown
For more information
If you have any questions or comments about this advisory:
- Come talk to us over on our Discord server in the #development channel
- Record
GHSA-h77f-xxx7-4858- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-287
- Updated
- 2026-11-02
NVD
7.4
Geyser is a bridge between Minecraft: Bedrock Edition and Minecraft: Java Edition. Versions of Geyser prior to 1.4.2-SNAPSHOT allow anyone that can connect to the server to forge a LoginPacket with manipulated JWT token allowing impersonation as any user. Version 1.4.2-SNAPSHOT contains a patch for the issue. There are no known workarounds aside from upgrading.
- Record
CVE-2021-39177- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-287
- Updated
- 2026-11-02
OSV
9.8
Geyser is a bridge between Minecraft: Bedrock Edition and Minecraft: Java Edition. Versions of Geyser prior to 1.4.2-SNAPSHOT allow anyone that can connect to the server to forge a LoginPacket with manipulated JWT token allowing impersonation as any user. Version 1.4.2-SNAPSHOT contains a patch for the issue. There are no known workarounds aside from upgrading.
- Record
CVE-2021-39177- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-h77f-xxx7-4858
7.4
User impersonation due to incorrect handling of the login JWT
Impact
<!--_What kind of vulnerability is it? Who is impacted?_-->
This allows anyone that can connect to the server to forge a LoginPacket with manipulated JWT token allowing impersonation as any Bedrock user. Unless credentials are saved in your configuration, online mode is not affected as users are still required to log in separately. If your credentials are saved, there is no risk of exposing your email or password.
Patches
<!--_Has the problem been patched? What versions should users upgrade to?_-->
This was patched as part of https://github.com/GeyserMC/Geyser/commit/b9541505af68ac7b7c093206ac7b1ba88957a5a6 and https://github.com/GeyserMC/Geyser/commit/ab2f5b326fe590e09167e8b45b4b165ac06ecd13. if your Geyser version is 1.4.2-SNAPSHOT or later, the issue has been addressed on your build.
Workarounds
<!--_Is there a way for users to fix or remediate the vulnerability without upgrading?_-->
Geyser strongly recommends updating to fix this issue. If this isn't possible:
- Use online mode and don't save credentials in your Geyser configuration
- Use an additional authentication method on the Java server
References
<!--_Are there any links users can visit to find out more?_-->
This was disclosed to us by a staff member over at Hive; you can read their disclosure here: https://updates.playhive.com/changelog/weekend-maintenance-breakdown
For more information
If you have any questions or comments about this advisory:
- Come talk to us over on our Discord server in the #development channel
- Record
GHSA-h77f-xxx7-4858- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-287
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.geysermc:connectorMaven |
before 1.4.2-SNAPSHOT | 1.4.2-SNAPSHOT |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-39177 is a high vulnerability (CVSS 7.4) in Geysermc Geyser, published August 30, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.44%, the 73rd percentile. Fixed in org.geysermc:connector 1.4.2-SNAPSHOT.
References
github.com/GeyserMC/Geyser/security/advisories/GHSA-h77f-xxx7-4858
github.com/GeyserMC/Geyser/commit/b9541505af68ac7b7c093206ac7b1ba88957a5a6
updates.playhive.com/weekend-maintenance-disclosure-2kJMaY
nvd.nist.gov/vuln/detail/CVE-2021-39177
updates.playhive.com/changelog/weekend-maintenance-breakdown
github.com/advisories/GHSA-h77f-xxx7-4858
github.com/GeyserMC/Geyser