Every CVE Search/ Get API key

CVE-2021-39206

Incorrect Authorization with specially crafted requests

8.6 HighFix available

Pomerium is an open source identity-aware access proxy. Envoy, which Pomerium is based on, contains two authorization related vulnerabilities CVE-2021-32777 and CVE-2021-32779. This may lead to incorrect routing or authorization policy decisions. With specially crafted requests, incorrect authorization or routing decisions may be made by Pomerium. Pomerium v0.14.8 and v0.15.1 contain an upgraded envoy binary with these vulnerabilities patched. This issue can only be triggered when using path prefix based policy. Removing any such policies should provide mitigation.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.46%Up 0.4 points since Sep 10, 2021
90%50%10%1%

What each source reports

CVE List Score used 8.6

Incorrect Authorization with specially crafted requests

Pomerium is an open source identity-aware access proxy. Envoy, which Pomerium is based on, contains two authorization related vulnerabilities CVE-2021-32777 and CVE-2021-32779. This may lead to incorrect routing or authorization policy decisions. With specially crafted requests, incorrect authorization or routing decisions may be made by Pomerium. Pomerium v0.14.8 and v0.15.1 contain an upgraded envoy binary with these vulnerabilities patched. This issue can only be triggered when using path prefix based policy. Removing any such policies should provide mitigation.

Record
CVE-2021-39206
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2021-2038 8.6

Pomerium is an open source identity-aware access proxy. Envoy, which Pomerium is based on, contains two authorization related vulnerabilities CVE-2021-32777 and CVE-2021-32779. This may lead to incorrect routing or authorization policy decisions. With specially crafted requests, incorrect authorization or routing decisions may be made by Pomerium. Pomerium v0.14.8 and v0.15.1 contain an upgraded envoy binary with these vulnerabilities patched. This issue can only be triggered when using path prefix based policy. Removing any such policies should provide mitigation.

Record
EUVD-2021-2038
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-cfc2-wjcm-c8fm 8.6

Incorrect Authorization with specially crafted requests

Envoy, which Pomerium is based on, contains two authorization related vulnerabilities:

  • CVE-2021-32777: incorrectly transform a URL containing a #fragment element, causing a mismatch in path-prefix based authorization decisions.
  • CVE-2021-32779: incorrectly handle duplicate headers, dropping all but the last. This may lead to incorrect routing or authorization policy decisions.

Impact

With specially crafted requests, incorrect authorization or routing decisions may be made by Pomerium.

Patches

Pomerium v0.14.8 and v0.15.1 contain an upgraded envoy binary with these vulnerabilities patched.

Workarounds

  • This issue can only be triggered when using path prefix based policy. Removing any such policies should provide mitigation.

References

envoy GSA CVE-2021-32777 envoy GSA CVE-2021-32779 envoy announcement

For more information

If you have any questions or comments about this advisory:

Record
GHSA-cfc2-wjcm-c8fm
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-863
Updated
2026-11-02
NVD 8.6

Pomerium is an open source identity-aware access proxy. Envoy, which Pomerium is based on, contains two authorization related vulnerabilities CVE-2021-32777 and CVE-2021-32779. This may lead to incorrect routing or authorization policy decisions. With specially crafted requests, incorrect authorization or routing decisions may be made by Pomerium. Pomerium v0.14.8 and v0.15.1 contain an upgraded envoy binary with these vulnerabilities patched. This issue can only be triggered when using path prefix based policy. Removing any such policies should provide mitigation.

Record
CVE-2021-39206
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-863
Updated
2026-11-02
OSV 8.6

Pomerium is an open source identity-aware access proxy. Envoy, which Pomerium is based on, contains two authorization related vulnerabilities CVE-2021-32777 and CVE-2021-32779. This may lead to incorrect routing or authorization policy decisions. With specially crafted requests, incorrect authorization or routing decisions may be made by Pomerium. Pomerium v0.14.8 and v0.15.1 contain an upgraded envoy binary with these vulnerabilities patched. This issue can only be triggered when using path prefix based policy. Removing any such policies should provide mitigation.

Record
CVE-2021-39206
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-cfc2-wjcm-c8fm 8.6

Incorrect Authorization with specially crafted requests

Envoy, which Pomerium is based on, contains two authorization related vulnerabilities:

  • CVE-2021-32777: incorrectly transform a URL containing a #fragment element, causing a mismatch in path-prefix based authorization decisions.
  • CVE-2021-32779: incorrectly handle duplicate headers, dropping all but the last. This may lead to incorrect routing or authorization policy decisions.

Impact

With specially crafted requests, incorrect authorization or routing decisions may be made by Pomerium.

Patches

Pomerium v0.14.8 and v0.15.1 contain an upgraded envoy binary with these vulnerabilities patched.

Workarounds

  • This issue can only be triggered when using path prefix based policy. Removing any such policies should provide mitigation.

References

envoy GSA CVE-2021-32777 envoy GSA CVE-2021-32779 envoy announcement

For more information

If you have any questions or comments about this advisory:

Record
GHSA-cfc2-wjcm-c8fm
CVSS 3.1
8.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-863
Updated
2026-11-02
OSVBIT-envoy-2021-39206 No score

Incorrect Authorization with specially crafted requests

Pomerium is an open source identity-aware access proxy. Envoy, which Pomerium is based on, contains two authorization related vulnerabilities CVE-2021-32777 and CVE-2021-32779. This may lead to incorrect routing or authorization policy decisions. With specially crafted requests, incorrect authorization or routing decisions may be made by Pomerium. Pomerium v0.14.8 and v0.15.1 contain an upgraded envoy binary with these vulnerabilities patched. This issue can only be triggered when using path prefix based policy. Removing any such policies should provide mitigation.

Record
BIT-envoy-2021-39206
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/pomerium/pomerium
Go
0.11.0 up to 0.14.8
0.14.8
github.com/pomerium/pomerium
Go
0.15.0 to 0.15.0
0.15.1
envoy
Bitnami
before 1.16.5, 1.17.0 up to 1.17.4, 1.18.0 up to 1.18.4, 1.19.0 up to 1.19.1
1.16.51.17.41.18.41.19.1
github.com/pomerium/pomerium
Go
0.15.0 up to 0.15.1
0.15.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-39206 is a high vulnerability (CVSS 8.6) in Envoyproxy Envoy, published September 9, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.46%, the 73rd percentile. Fixed in github.com/pomerium/pomerium 0.14.8.

References

MoveEnter Open