Every CVE Search/ Get API key

CVE-2021-39217

OpenMage LTS arbitrary command execution in custom layout update through blocks

7.2 HighFix available

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Custom Layout enabled admin users to execute arbitrary commands via block methods. Versions 19.4.22 and 20.0.19 contain patches for this issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.38%Up 0.4 points since Jan 28, 2023
90%50%10%1%

What each source reports

CVE List Score used 7.2

OpenMage LTS arbitrary command execution in custom layout update through blocks

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Custom Layout enabled admin users to execute arbitrary commands via block methods. Versions 19.4.22 and 20.0.19 contain patches for this issue.

Record
CVE-2021-39217
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
EUVDEUVD-2023-0442 7.2

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Custom Layout enabled admin users to execute arbitrary commands via block methods. Versions 19.4.22 and 20.0.19 contain patches for this issue.

Record
EUVD-2023-0442
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-c9q3-r4rv-mjm7 7.2

Fix for arbitrary command execution in custom layout update through blocks

Impact

Custom Layout enabled admin users to execute arbitrary commands via block methods.

Record
GHSA-c9q3-r4rv-mjm7
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
NVD 7.2

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Custom Layout enabled admin users to execute arbitrary commands via block methods. Versions 19.4.22 and 20.0.19 contain patches for this issue.

Record
CVE-2021-39217
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
OSV 7.2

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Custom Layout enabled admin users to execute arbitrary commands via block methods. Versions 19.4.22 and 20.0.19 contain patches for this issue.

Record
CVE-2021-39217
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-c9q3-r4rv-mjm7 7.2

Fix for arbitrary command execution in custom layout update through blocks

Impact

Custom Layout enabled admin users to execute arbitrary commands via block methods.

Record
GHSA-c9q3-r4rv-mjm7
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openmage/magento-lts
Packagist
before 19.4.22
19.4.22
openmage/magento-lts
Packagist
20.0.0 up to 20.0.19
20.0.19
openmage/magento-lts
Packagist
before 19.4.22, plus listed versions
1.9.1.11.9.2.01.9.2.11.9.2.21.9.2.3
Show 25 moreShow less
1.9.2.41.9.3.01.9.3.1v19.4.0v19.4.1v19.4.10v19.4.11v19.4.12v19.4.13v19.4.14v19.4.15v19.4.16v19.4.17v19.4.18v19.4.19v19.4.2v19.4.20v19.4.21v19.4.3v19.4.4v19.4.5v19.4.6v19.4.7v19.4.8v19.4.9
19.4.22
openmage/magento-lts
Packagist
20.0.0 up to 20.0.19, plus listed versions
v20.0.0v20.0.1v20.0.10v20.0.11v20.0.12
Show 13 moreShow less
v20.0.13v20.0.14v20.0.15v20.0.16v20.0.17v20.0.18v20.0.2v20.0.3v20.0.4v20.0.5v20.0.6v20.0.7v20.0.8
20.0.19

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-39217 is a high vulnerability (CVSS 7.2) in Openmage Magento, published January 27, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.38%, the 72nd percentile. Fixed in openmage/magento-lts 19.4.22.

References

MoveEnter Open