CVE-2021-39371
XML External Entity Injection in PyWPS
An XML external entity (XXE) injection in PyWPS before 4.4.5 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
An XML external entity (XXE) injection in PyWPS before 4.4.5 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
- Record
CVE-2021-39371- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-611
- Updated
- 2026-11-02
CVE List No score
An XML external entity (XXE) injection in PyWPS before 4.4.5 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
- Record
CVE-2021-39371- Updated
- 2026-11-02
EUVDEUVD-2021-0215 No score
An XML external entity (XXE) injection in PyWPS before 4.4.5 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
- Record
EUVD-2021-0215- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p9wf-3xpg-c9g5
8.7
XML External Entity Injection in PyWPS
An XML external entity (XXE) injection in PyWPS before 4.5.0 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
- Record
GHSA-p9wf-3xpg-c9g5- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-91, CWE-611
- Updated
- 2026-11-02
OSV
7.5
An XML external entity (XXE) injection in PyWPS before 4.4.5 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
- Record
CVE-2021-39371- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-39371
7.5
An XML external entity (XXE) injection in PyWPS before 4.4.5 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
- Record
DEBIAN-CVE-2021-39371- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-p9wf-3xpg-c9g5
8.7
XML External Entity Injection in PyWPS
An XML external entity (XXE) injection in PyWPS before 4.5.0 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
- Record
GHSA-p9wf-3xpg-c9g5- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-611, CWE-91
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-39371
7.5
An XML external entity (XXE) injection in PyWPS before 4.4.5 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
- Record
UBUNTU-CVE-2021-39371- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVPYSEC-2021-121 No score
An XML external entity (XXE) injection in PyWPS before 4.5.0 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
- Record
PYSEC-2021-121- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pywpsPyPI |
before 4.5.0 | 4.5.0 |
pywpsDebian:12 |
before 4.5.0-1 | 4.5.0-1 |
pywpsDebian:13 |
before 4.5.0-1 | 4.5.0-1 |
pywpsDebian:14 |
before 4.5.0-1 | 4.5.0-1 |
pywpsDebian:9 |
before 4.0.0-3+deb9u1, plus listed versions 4.0.0-3 |
4.0.0-3+deb9u1 |
pywpsPyPI |
before 4.5.0, plus listed versions 3.2.33.2.43.2.53.2.64.0.0 Show 19 moreShow less4.2.04.2.14.2.104.2.114.2.24.2.34.2.44.2.54.2.64.2.74.2.84.2.94.4.04.4.14.4.24.4.34.4.44.4.5trunk |
4.5.0 |
pywpsUbuntu:18.04:LTS |
All versions, plus listed versions 4.0.0-44.0.0-5 |
None known |
pywpsUbuntu:20.04:LTS |
All versions, plus listed versions 4.2.1-1ubuntu14.2.2-14.2.3-14.2.4-1 |
None known |
pywpsUbuntu:22.04:LTS |
All versions, plus listed versions 4.2.11-14.5.0-14.5.1-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-39371 is a high vulnerability (CVSS 7.5) in Osgeo Owslib, published August 23, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.52%, the 74th percentile. Fixed in pywps 4.5.0.