Every CVE Search/ Get API key

CVE-2021-3938

Cross-site Scripting (XSS) - Generic in snipe/snipe-it

3.9 LowFix available

snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.54%Down 0.1 points since Nov 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 3.9

Cross-site Scripting (XSS) - Generic in snipe/snipe-it

snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Record
CVE-2021-3938
CVSS 3.0
3.9 LowCVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2021-2278 3.9

snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Record
EUVD-2021-2278
CVSS 3.0
3.9 LowCVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-2cqg-q7jm-j35c 3.9

snipe-it is vulnerable to Cross-site Scripting

snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').

Record
GHSA-2cqg-q7jm-j35c
CVSS 3.0
3.9 LowCVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 5.4

snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Record
CVE-2021-3938
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
3.9 LowCVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Record
CVE-2021-3938
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-2cqg-q7jm-j35c 3.9

snipe-it is vulnerable to Cross-site Scripting

snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').

Record
GHSA-2cqg-q7jm-j35c
CVSS 3.0
3.9 LowCVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
snipe/snipe-it
Packagist
through 5.3.1
5.4.0
snipe/snipe-it
Packagist
before 5.4.0, plus listed versions
3.2.0v0.1.0v0.1.1v0.1.2v0.2.0
Show 45 moreShow less
v0.3.0-alphav0.3.10-alphav0.3.11-alphav0.3.7-alphav0.3.8-alphav0.3.9-alphav1.0v1.1v1.2.0v1.2.1v1.2.10v1.2.11v1.2.2v1.2.3v1.2.3-betav1.2.4v1.2.4-betav1.2.5v1.2.6v1.2.6-betav1.2.6.1v1.2.7v1.2.7-betav1.2.8v1.2.9v2.0v2.0-RC-1v2.0-betav2.0.1v2.0.2v2.0.3v2.0.4v2.0.5v2.0.6v2.1.0v2.1.1v2.1.2v3.0v3.0-alphav3.0-alpha2v3.0-beta.1v3.0-beta.2v3.0-beta.3v3.0.0-betav3.1.0
5.4.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-3938 is a low vulnerability (CVSS 3.9) in Snipe Snipe/snipe-it, published November 13, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in snipe/snipe-it 5.4.0.

References

This page doesn't list everything

Left out here: 138 versions. The JSON record has them.

MoveEnter Open