CVE-2021-3985
Cross-site Scripting (XSS) - Stored in kevinpapst/kimai2
kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.0
Cross-site Scripting (XSS) - Stored in kevinpapst/kimai2
kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
- Record
CVE-2021-3985- CVSS 3.0
- 8.0 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2021-2609
8.0
kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
- Record
EUVD-2021-2609- CVSS 3.0
- 8.0 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x68c-4gmm-5g43
8.0
kimai2 is vulnerable to Cross-site Scripting
kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').
- Record
GHSA-x68c-4gmm-5g43- CVSS 3.0
- 8.0 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
9.0
kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
- Record
CVE-2021-3985- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - CVSS 3.0
- 8.0 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.0 Medium
AV:N/AC:M/Au:S/C:P/I:P/A:P - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
9.0
kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
- Record
CVE-2021-3985- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-x68c-4gmm-5g43
8.0
kimai2 is vulnerable to Cross-site Scripting
kimai2 is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').
- Record
GHSA-x68c-4gmm-5g43- CVSS 3.0
- 8.0 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
kevinpapst/kimai2Packagist |
before 1.16.3 | 1.16.3 |
kevinpapst/kimai2Packagist |
before 1.16.3, plus listed versions 0.10.20.30.40.5 Show 42 moreShow less0.60.6.10.70.80.8.10.91.01.0.11.11.101.10.11.10.21.111.11.11.121.131.141.14.11.14.21.14.31.151.15.11.15.21.15.31.15.41.15.51.15.61.161.16.11.16.21.21.31.41.4.11.4.21.51.61.6.11.6.21.71.81.9 |
1.16.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-3985 is a high vulnerability (CVSS 8.0) in Kevinpapst Kevinpapst/kimai2, published December 1, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.26%, the 69th percentile. Fixed in kevinpapst/kimai2 1.16.3.