CVE-2021-3992
Improper Access Control in kevinpapst/kimai2
kimai2 is vulnerable to Improper Access Control
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Improper Access Control in kevinpapst/kimai2
kimai2 is vulnerable to Improper Access Control
- Record
CVE-2021-3992- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
EUVDEUVD-2021-2499
6.5
kimai2 is vulnerable to Improper Access Control
- Record
EUVD-2021-2499- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9w8f-7wgr-2h7g
6.5
kimai2 is vulnerable to Improper Access Control
kimai2 is vulnerable to Improper Access Control
- Record
GHSA-9w8f-7wgr-2h7g- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-284, CWE-639, CWE-863
- Updated
- 2026-11-02
NVD
6.5
kimai2 is vulnerable to Improper Access Control
- Record
CVE-2021-3992- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-284, CWE-639
- Updated
- 2026-11-02
OSV
6.5
kimai2 is vulnerable to Improper Access Control
- Record
CVE-2021-3992- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-9w8f-7wgr-2h7g
6.5
kimai2 is vulnerable to Improper Access Control
kimai2 is vulnerable to Improper Access Control
- Record
GHSA-9w8f-7wgr-2h7g- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-284, CWE-639, CWE-863
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
kevinpapst/kimai2Packagist |
before 1.16.3 | 1.16.3 |
kevinpapst/kimai2Packagist |
before 1.16.3, plus listed versions 0.10.20.30.40.5 Show 42 moreShow less0.60.6.10.70.80.8.10.91.01.0.11.11.101.10.11.10.21.111.11.11.121.131.141.14.11.14.21.14.31.151.15.11.15.21.15.31.15.41.15.51.15.61.161.16.11.16.21.21.31.41.4.11.4.21.51.61.6.11.6.21.71.81.9 |
1.16.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-3992 is a medium vulnerability (CVSS 6.5) in Kevinpapst Kevinpapst/kimai2, published December 1, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.06%, the 64th percentile. Fixed in kevinpapst/kimai2 1.16.3.