CVE-2021-4015
Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.3
Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
- Record
CVE-2021-4015- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
EUVDEUVD-2021-2518
4.3
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
- Record
EUVD-2021-2518- CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g6vq-wc8w-4g69
4.3
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF).
- Record
GHSA-g6vq-wc8w-4g69- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
NVD
4.3
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
- Record
CVE-2021-4015- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - CVSS 3.0
- 4.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV
4.3
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
- Record
CVE-2021-4015- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-g6vq-wc8w-4g69
4.3
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF)
firefly-iii is vulnerable to Cross-Site Request Forgery (CSRF).
- Record
GHSA-g6vq-wc8w-4g69- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
grumpydictator/firefly-iiiPackagist |
before 5.6.5 | 5.6.5 |
grumpydictator/firefly-iiiPackagist |
before 5.6.5, plus listed versions 3.0.03.0.13.0.23.0.33.1 Show 45 moreShow less3.1.13.1.23.1.33.1.43.1.53.1.63.103.10.13.10.23.10.33.10.43.2.03.2.13.2.23.2.33.2.43.2.53.33.3.13.3.23.3.33.3.43.3.53.3.63.3.73.3.83.3.93.43.4.0.13.4.0.103.4.0.23.4.0.33.4.0.43.4.0.53.4.0.63.4.0.73.4.0.83.4.0.93.4.13.4.103.4.113.4.23.4.33.4.43.4.4.1 |
5.6.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-4015 is a medium vulnerability (CVSS 4.3) in Firefly-iii Firefly-iii/firefly-iii, published December 1, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in grumpydictator/firefly-iii 5.6.5.
References
huntr.dev/bounties/b698d445-602d-4701-961c-dffe6d3009b1
github.com/firefly-iii/firefly-iii/commit/518b4ba5a7a56760902758ae0a2c6a392c2f4d37
nvd.nist.gov/vuln/detail/CVE-2021-4015
github.com/firefly-iii/firefly-iii/releases/tag/5.6.5
github.com/advisories/GHSA-g6vq-wc8w-4g69
github.com/firefly-iii/firefly-iii
Left out here: 201 versions. The JSON record has them.