Every CVE Search/ Get API key

CVE-2021-41038

Improper Verification of Communication Channel in @theia/plugin-ext

6.1 MediumFix available

In versions of the @theia/plugin-ext component of Eclipse Theia prior to 1.18.0, Webview contents can be hijacked via postMessage().

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.74%Up 0.1 points since Nov 11, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

In versions of the @theia/plugin-ext component of Eclipse Theia prior to 1.18.0, Webview contents can be hijacked via postMessage().

Record
CVE-2021-41038
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-940
Updated
2026-11-02
CVE List No score

In versions of the @theia/plugin-ext component of Eclipse Theia prior to 1.18.0, Webview contents can be hijacked via postMessage().

Record
CVE-2021-41038
Weakness
CWE-940
Updated
2026-11-02
EUVDEUVD-2021-2403 No score

In versions of the @theia/plugin-ext component of Eclipse Theia prior to 1.18.0, Webview contents can be hijacked via postMessage().

Record
EUVD-2021-2403
Updated
2026-11-03
GitHub AdvisoriesGHSA-w6v7-w58j-pg5r 6.1

Improper Verification of Communication Channel in @theia/plugin-ext

In versions of the @theia/plugin-ext component of Eclipse Theia prior to 1.18.0, Webview contents can be hijacked via postMessage().

Record
GHSA-w6v7-w58j-pg5r
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-940
Updated
2026-11-02
OSV 6.1

In versions of the @theia/plugin-ext component of Eclipse Theia prior to 1.18.0, Webview contents can be hijacked via postMessage().

Record
CVE-2021-41038
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-w6v7-w58j-pg5r 6.1

Improper Verification of Communication Channel in @theia/plugin-ext

In versions of the @theia/plugin-ext component of Eclipse Theia prior to 1.18.0, Webview contents can be hijacked via postMessage().

Record
GHSA-w6v7-w58j-pg5r
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-940
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
@theia/plugin-ext
npm
before 1.18.0
1.18.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-41038 is a medium vulnerability (CVSS 6.1) in Eclipse Theia, published November 10, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. Fixed in @theia/plugin-ext 1.18.0.

References

MoveEnter Open