Every CVE Search/ Get API key

CVE-2021-41055

Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash)...

7.5 HighFix available

Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted XMPP Last Message Correction (XEP-0308) message in multi-user chat, where the message ID equals the correction ID.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.57%Up 0.6 points since Oct 11, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted XMPP Last Message Correction (XEP-0308) message in multi-user chat, where the message ID equals the correction ID.

Record
CVE-2021-41055
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted XMPP Last Message Correction (XEP-0308) message in multi-user chat, where the message ID equals the correction ID.

Record
CVE-2021-41055
Updated
2026-11-02
EUVDEUVD-2021-28206 No score

Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted XMPP Last Message Correction (XEP-0308) message in multi-user chat, where the message ID equals the correction ID.

Record
EUVD-2021-28206
Updated
2026-11-03
GitHub AdvisoriesGHSA-r23x-224g-484r No score

Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash)...

Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted XMPP Last Message Correction (XEP-0308) message in multi-user chat, where the message ID equals the correction ID.

Record
GHSA-r23x-224g-484r
Updated
2026-11-02
OSV 7.5

Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted XMPP Last Message Correction (XEP-0308) message in multi-user chat, where the message ID equals the correction ID.

Record
CVE-2021-41055
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-41055 7.5

Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted XMPP Last Message Correction (XEP-0308) message in multi-user chat, where the message ID equals the correction ID.

Record
DEBIAN-CVE-2021-41055
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-41055 7.5

Gajim 1.2.x and 1.3.x before 1.3.3 allows remote attackers to cause a denial of service (crash) via a crafted XMPP Last Message Correction (XEP-0308) message in multi-user chat, where the message ID equals the correction ID.

Record
UBUNTU-CVE-2021-41055
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2022-0179 No score

Updated python-nbxmpp packages fix security vulnerability

Missing input sanitising in python-nbxmpp, a Jabber/XMPP Python library, could result in denial of service in clients based on it (such as Gajim).

Record
MGASA-2022-0179
Updated
2026-11-02
OSVopenSUSE-SU-2024:11734-1 No score

gajim-1.3.3-1.1 on GA media

These are all security issues fixed in the gajim-1.3.3-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11734-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
python-nbxmpp
Debian:12
before 2.0.4-1
2.0.4-1
python-nbxmpp
Debian:13
before 2.0.4-1
2.0.4-1
python-nbxmpp
Debian:14
before 2.0.4-1
2.0.4-1
python-nbxmpp
Debian:11
before 2.0.2-1+deb11u1, plus listed versions
2.0.2-1
2.0.2-1+deb11u1
python-nbxmpp
Mageia:8
before 2.0.4-1.mga8
2.0.4-1.mga8
python-nbxmpp
Ubuntu:16.04:LTS
All versions, plus listed versions
0.5.1-20.5.3-1
None known
gajim
openSUSE:Tumbleweed
before 1.3.3-1.1
1.3.3-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-41055 is a high vulnerability (CVSS 7.5) in Gajim, published October 11, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in python-nbxmpp 2.0.4-1.

References

Show 6 moreShow less
MoveEnter Open