Every CVE Search/ Get API key

CVE-2021-41188

Authenticated Stored XSS in Administration

5.7 MediumFix available

Shopware is open source e-commerce software. Versions prior to 5.7.6 contain a cross-site scripting vulnerability. This issue is patched in version 5.7.6. Two workarounds are available. Using the security plugin or adding a particular following config to the .htaccess file will protect against cross-site scripting in this case. There is also a config for those using nginx as a server. The plugin and the configs can be found on the GitHub Security Advisory page for this vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.76%Down 0.5 points since Oct 27, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.7

Authenticated Stored XSS in Administration

Shopware is open source e-commerce software. Versions prior to 5.7.6 contain a cross-site scripting vulnerability. This issue is patched in version 5.7.6. Two workarounds are available. Using the security plugin or adding a particular following config to the .htaccess file will protect against cross-site scripting in this case. There is also a config for those using nginx as a server. The plugin and the configs can be found on the GitHub Security Advisory page for this vulnerability.

Record
CVE-2021-41188
CVSS 3.1
5.7 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2021-2156 5.7

Shopware is open source e-commerce software. Versions prior to 5.7.6 contain a cross-site scripting vulnerability. This issue is patched in version 5.7.6. Two workarounds are available. Using the security plugin or adding a particular following config to the .htaccess file will protect against cross-site scripting in this case. There is also a config for those using nginx as a server. The plugin and the configs can be found on the GitHub Security Advisory page for this vulnerability.

Record
EUVD-2021-2156
CVSS 3.1
5.7 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-4p3x-8qw9-24w9 5.7

Authenticated Stored XSS in shopware/shopware

Impact

Authenticated Stored XSS in Administration

Patches

Use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html

Workarounds

If you cannot use the security plugin, add the following config to your .htaccess file

<IfModule mod_headers.c>
    <FilesMatch "\.(?i:svg)$">
        Header set Content-Security-Policy "script-src 'none'"
    </FilesMatch>
</IfModule>

If you are using nginx as server config, you can add the following to your configuration:

server {
    # ...

    location ~* ^.+\.svg$ {
        add_header Content-Security-Policy "script-src 'none'";
    }
}

References

https://docs.shopware.com/en/shopware-5-en/sicherheitsupdates/security-update-10-2021

Record
GHSA-4p3x-8qw9-24w9
CVSS 3.1
5.7 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 5.7

Shopware is open source e-commerce software. Versions prior to 5.7.6 contain a cross-site scripting vulnerability. This issue is patched in version 5.7.6. Two workarounds are available. Using the security plugin or adding a particular following config to the .htaccess file will protect against cross-site scripting in this case. There is also a config for those using nginx as a server. The plugin and the configs can be found on the GitHub Security Advisory page for this vulnerability.

Record
CVE-2021-41188
CVSS 3.1
5.7 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-4p3x-8qw9-24w9 5.7

Authenticated Stored XSS in shopware/shopware

Impact

Authenticated Stored XSS in Administration

Patches

Use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html

Workarounds

If you cannot use the security plugin, add the following config to your .htaccess file

<IfModule mod_headers.c>
    <FilesMatch "\.(?i:svg)$">
        Header set Content-Security-Policy "script-src 'none'"
    </FilesMatch>
</IfModule>

If you are using nginx as server config, you can add the following to your configuration:

server {
    # ...

    location ~* ^.+\.svg$ {
        add_header Content-Security-Policy "script-src 'none'";
    }
}

References

https://docs.shopware.com/en/shopware-5-en/sicherheitsupdates/security-update-10-2021

Record
GHSA-4p3x-8qw9-24w9
CVSS 3.1
5.7 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
shopware/shopware
Packagist
before 5.7.6
5.7.6
shopware/shopware
Packagist
before 5.7.6, plus listed versions
1.0.21.0.84.2.04.2.0-rc.14.2.1
Show 45 moreShow less
4.2.1.14.2.24.2.34.3.04.3.14.3.24.3.34.3.44.3.54.3.64.3.75.3.0v5.0.0v5.0.0-BETA1v5.0.0-BETA2v5.0.0-RC1v5.0.0-RC2v5.0.0-RC3v5.0.1v5.0.2v5.0.2-RC1v5.0.3v5.0.3-RC1v5.0.4v5.0.4-RC1v5.1.0v5.1.0-RC2v5.1.0-RC3v5.1.1v5.1.2v5.1.2-RC1v5.1.2-RC2v5.1.3v5.1.3-RC1v5.1.4v5.1.5v5.1.6v5.2.0v5.2.0-BETA1v5.2.0-RC1v5.2.0-RC2v5.2.0-RC3v5.2.1v5.2.10v5.2.11
5.7.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-41188 is a medium vulnerability (CVSS 5.7) in Shopware, published October 26, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.76%, the 55th percentile. Fixed in shopware/shopware 5.7.6.

References

This page doesn't list everything

Left out here: 69 versions. The JSON record has them.

MoveEnter Open