CVE-2021-41231
OpenMage LTS DataFlow upload remote code execution vulnerability
OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, an administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile. Versions 19.4.22 and 20.0.19 contain a patch for this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.2
OpenMage LTS DataFlow upload remote code execution vulnerability
OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, an administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile. Versions 19.4.22 and 20.0.19 contain a patch for this issue.
- Record
CVE-2021-41231- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
EUVDEUVD-2023-0479
7.2
OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, an administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile. Versions 19.4.22 and 20.0.19 contain a patch for this issue.
- Record
EUVD-2023-0479- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-h632-p764-pjqm
7.2
DataFlow upload remote code execution vulnerability
Impact
An administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile.
- Record
GHSA-h632-p764-pjqm- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77, CWE-434
- Updated
- 2026-11-02
NVD
7.2
OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, an administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile. Versions 19.4.22 and 20.0.19 contain a patch for this issue.
- Record
CVE-2021-41231- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77, CWE-434
- Updated
- 2026-11-02
OSV
7.2
OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, an administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile. Versions 19.4.22 and 20.0.19 contain a patch for this issue.
- Record
CVE-2021-41231- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-h632-p764-pjqm
7.2
DataFlow upload remote code execution vulnerability
Impact
An administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile.
- Record
GHSA-h632-p764-pjqm- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-434, CWE-77
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openmage/magento-ltsPackagist |
before 19.4.22 | 19.4.22 |
openmage/magento-ltsPackagist |
20.0.0 up to 20.0.19 | 20.0.19 |
openmage/magento-ltsPackagist |
before 19.4.22, plus listed versions 1.9.1.11.9.2.01.9.2.11.9.2.21.9.2.3 Show 25 moreShow less1.9.2.41.9.3.01.9.3.1v19.4.0v19.4.1v19.4.10v19.4.11v19.4.12v19.4.13v19.4.14v19.4.15v19.4.16v19.4.17v19.4.18v19.4.19v19.4.2v19.4.20v19.4.21v19.4.3v19.4.4v19.4.5v19.4.6v19.4.7v19.4.8v19.4.9 |
19.4.22 |
openmage/magento-ltsPackagist |
20.0.0 up to 20.0.19, plus listed versions v20.0.0v20.0.1v20.0.10v20.0.11v20.0.12 Show 13 moreShow lessv20.0.13v20.0.14v20.0.15v20.0.16v20.0.17v20.0.18v20.0.2v20.0.3v20.0.4v20.0.5v20.0.6v20.0.7v20.0.8 |
20.0.19 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-41231 is a high vulnerability (CVSS 7.2) in Openmage Magento, published January 27, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.23%, the 69th percentile. Fixed in openmage/magento-lts 19.4.22.
References
github.com/OpenMage/magento-lts/security/advisories/GHSA-h632-p764-pjqm
github.com/OpenMage/magento-lts/commit/d16fc6c5a1e66c6f0d9f82020f11702a7ddd78e4
github.com/OpenMage/magento-lts/releases/tag/v19.4.22
github.com/OpenMage/magento-lts/releases/tag/v20.0.19
nvd.nist.gov/vuln/detail/CVE-2021-41231
github.com/advisories/GHSA-h632-p764-pjqm
github.com/OpenMage/magento-lts