CVE-2021-41387
seatd-launch in seatd 0.6.x before 0.6.2 allows privilege escalation because it uses execlp and...
seatd-launch in seatd 0.6.x before 0.6.2 allows privilege escalation because it uses execlp and may be installed setuid root.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
seatd-launch in seatd 0.6.x before 0.6.2 allows privilege escalation because it uses execlp and may be installed setuid root.
- Record
CVE-2021-41387- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 8.5 High
AV:N/AC:M/Au:S/C:C/I:C/A:C - Weakness
- CWE-426
- Updated
- 2026-11-02
CVE List No score
seatd-launch in seatd 0.6.x before 0.6.2 allows privilege escalation because it uses execlp and may be installed setuid root.
- Record
CVE-2021-41387- Updated
- 2026-11-02
EUVDEUVD-2021-28415 No score
seatd-launch in seatd 0.6.x before 0.6.2 allows privilege escalation because it uses execlp and may be installed setuid root.
- Record
EUVD-2021-28415- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rcqm-vg32-925j
8.8
seatd-launch in seatd 0.6.x before 0.6.2 allows privilege escalation because it uses execlp and...
seatd-launch in seatd 0.6.x before 0.6.2 allows privilege escalation because it uses execlp and may be installed setuid root.
- Record
GHSA-rcqm-vg32-925j- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVALPINE-CVE-2021-41387
8.8
seatd-launch in seatd 0.6.x before 0.6.2 allows privilege escalation because it uses execlp and may be installed setuid root.
- Record
ALPINE-CVE-2021-41387- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
seatdAlpine:v3.15 |
0.6.0 up to 0.6.2-r0 | 0.6.2-r0 |
seatdAlpine:v3.16 |
0.6.0 up to 0.6.2-r0 | 0.6.2-r0 |
seatdAlpine:v3.17 |
0.6.0 up to 0.6.2-r0 | 0.6.2-r0 |
seatdAlpine:v3.18 |
0.6.0 up to 0.6.2-r0 | 0.6.2-r0 |
seatdAlpine:v3.19 |
0.6.0 up to 0.6.2-r0 | 0.6.2-r0 |
seatdAlpine:v3.20 |
0.6.0 up to 0.6.2-r0 | 0.6.2-r0 |
seatdAlpine:v3.21 |
0.6.0 up to 0.6.2-r0 | 0.6.2-r0 |
seatdAlpine:v3.22 |
0.6.0 up to 0.6.2-r0 | 0.6.2-r0 |
seatdAlpine:v3.23 |
0.6.0 up to 0.6.2-r0 | 0.6.2-r0 |
seatdAlpine:v3.24 |
0.6.0 up to 0.6.2-r0 | 0.6.2-r0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, facts, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-41387 is a high vulnerability (CVSS 8.8) in Seatd Project Seatd, published September 17, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.06%, the 64th percentile. Fixed in seatd 0.6.2-r0.