CVE-2021-41499
Classic Buffer Overflow in pyo
Buffer Overflow Vulnerability exists in ajaxsoundstudio.com n Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Buffer Overflow Vulnerability exists in ajaxsoundstudio.com n Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
- Record
CVE-2021-41499- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List No score
Buffer Overflow Vulnerability exists in ajaxsoundstudio.com n Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
- Record
CVE-2021-41499- Updated
- 2026-11-02
EUVDEUVD-2022-0464 No score
Buffer Overflow Vulnerability exists in ajaxsoundstudio.com n Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
- Record
EUVD-2022-0464- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5f5c-687x-g5qm
7.5
Classic Buffer Overflow in pyo
Buffer Overflow Vulnerability exists in ajaxsoundstudio.com in Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
- Record
GHSA-5f5c-687x-g5qm- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSV
7.5
Buffer Overflow Vulnerability exists in ajaxsoundstudio.com n Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
- Record
CVE-2021-41499- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-41499
7.5
Buffer Overflow Vulnerability exists in ajaxsoundstudio.com n Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
- Record
DEBIAN-CVE-2021-41499- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-5f5c-687x-g5qm
7.5
Classic Buffer Overflow in pyo
Buffer Overflow Vulnerability exists in ajaxsoundstudio.com in Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
- Record
GHSA-5f5c-687x-g5qm- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSVPYSEC-2026-743
7.5
Classic Buffer Overflow in pyo
Buffer Overflow Vulnerability exists in ajaxsoundstudio.com in Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
- Record
PYSEC-2026-743- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-41499
7.5
Buffer Overflow Vulnerability exists in ajaxsoundstudio.com n Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
- Record
UBUNTU-CVE-2021-41499- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pyoPyPI |
before 1.0.3 | 1.0.3 |
python-pyoDebian:12 |
before 1.0.4-1 | 1.0.4-1 |
python-pyoDebian:13 |
before 1.0.4-1 | 1.0.4-1 |
python-pyoDebian:14 |
before 1.0.4-1 | 1.0.4-1 |
pyoPyPI |
before 1.0.3, plus listed versions 1.0.01.0.11.0.2 |
1.0.3 |
python-pyoUbuntu:16.04:LTS |
All versions, plus listed versions 0.7.6-10.7.6+git20150902.a1d7123d76-10.7.8-10.7.8+git20160129-1 |
None known |
python-pyoUbuntu:18.04:LTS |
All versions, plus listed versions 0.8.6-1build20.8.7-10.8.8-1 |
None known |
python-pyoUbuntu:20.04:LTS |
All versions, plus listed versions 0.9.1-10.9.1-1build11.0.0-21.0.0-2.11.0.0-2.1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-41499 is a high vulnerability (CVSS 7.5) in Pyo Project Pyo, published December 17, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.41%, the 72nd percentile. Fixed in pyo 1.0.3.
References
github.com/belangeo/pyo/issues/222
nvd.nist.gov/vuln/detail/CVE-2021-41499
github.com/advisories/GHSA-5f5c-687x-g5qm
security-tracker.debian.org/tracker/CVE-2021-41499
github.com/belangeo/pyo
pypi.org/project/pyo
ubuntu.com/security/CVE-2021-41499
github.com/belangeo/pyo/commit/e7e6d2880469b523e4c41f0da2087a6a3eec4a45
cve.org/CVERecord?id=CVE-2021-41499