Every CVE Search/ Get API key

CVE-2021-4178

fabric8 kubernetes-client vulnerable

6.7 MediumPublic exploitFix available

A arbitrary code execution flaw was found in the Fabric 8 Kubernetes client affecting versions 5.0.0-beta-1 and above. Due to an improperly configured YAML parsing, this will allow a local and privileged attacker to supply malicious YAML.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.34%Down 1.2 points since Aug 25, 2022
90%50%10%1%

What each source reports

NVD Score used 6.7

A arbitrary code execution flaw was found in the Fabric 8 Kubernetes client affecting versions 5.0.0-beta-1 and above. Due to an improperly configured YAML parsing, this will allow a local and privileged attacker to supply malicious YAML.

Record
CVE-2021-4178
CVSS 3.1
6.7 MediumCVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
CVE List No score

A arbitrary code execution flaw was found in the Fabric 8 Kubernetes client affecting versions 5.0.0-beta-1 and above. Due to an improperly configured YAML parsing, this will allow a local and privileged attacker to supply malicious YAML.

Record
CVE-2021-4178
Weakness
CWE-502
Updated
2026-11-02
EUVDEUVD-2022-6304 No score

A arbitrary code execution flaw was found in the Fabric 8 Kubernetes client affecting versions 5.0.0-beta-1 and above. Due to an improperly configured YAML parsing, this will allow a local and privileged attacker to supply malicious YAML.

Record
EUVD-2022-6304
Updated
2026-11-03
GitHub AdvisoriesGHSA-98g7-rxmf-rrxm 6.7

fabric8 kubernetes-client vulnerable

fabric8 Kubernetes client had an arbitrary code execution flaw in versions 5.0.0-beta-1 and higher. Attackers could potentially insert malicious YAMLs due to misconfigured YAML parsing.

Record
GHSA-98g7-rxmf-rrxm
CVSS 3.1
6.7 MediumCVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94, CWE-502
Updated
2026-11-02
OSV 6.7

A arbitrary code execution flaw was found in the Fabric 8 Kubernetes client affecting versions 5.0.0-beta-1 and above. Due to an improperly configured YAML parsing, this will allow a local and privileged attacker to supply malicious YAML.

Record
CVE-2021-4178
CVSS 3.1
6.7 MediumCVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-98g7-rxmf-rrxm 6.7

fabric8 kubernetes-client vulnerable

fabric8 Kubernetes client had an arbitrary code execution flaw in versions 5.0.0-beta-1 and higher. Attackers could potentially insert malicious YAMLs due to misconfigured YAML parsing.

Record
GHSA-98g7-rxmf-rrxm
CVSS 3.1
6.7 MediumCVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502, CWE-94
Updated
2026-11-02
OSVRHSA-2023:3299 9.8

Red Hat Security Advisory: jenkins and jenkins-2-plugins security update

Record
RHSA-2023:3299
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
io.fabric8:kubernetes-client
Maven
5.0.0-beta-1 up to 5.0.3
5.0.3
io.fabric8:kubernetes-client
Maven
5.1.0 up to 5.1.2
5.1.2
io.fabric8:kubernetes-client
Maven
5.2.0 up to 5.3.2
5.3.2
io.fabric8:kubernetes-client
Maven
5.5.0 up to 5.7.4
5.7.4
io.fabric8:kubernetes-client
Maven
5.8.0 up to 5.8.1
5.8.1
io.fabric8:kubernetes-client
Maven
5.9.0 up to 5.10.2
5.10.2
io.fabric8:kubernetes-client
Maven
5.11.0 up to 5.11.2
5.11.2
io.fabric8:kubernetes-client
Maven
5.0.0-beta-1 up to 5.0.3, plus listed versions
5.0.05.0.15.0.2
5.0.3
io.fabric8:kubernetes-client
Maven
5.1.0 up to 5.1.2, plus listed versions
5.1.1
5.1.2
io.fabric8:kubernetes-client
Maven
5.2.0 up to 5.3.2, plus listed versions
5.2.15.3.05.3.1
5.3.2
Show 5 moreShow less
Affected packages
PackageAffectedFixed
io.fabric8:kubernetes-client
Maven
5.5.0 up to 5.7.4, plus listed versions
5.6.05.7.05.7.15.7.25.7.3
5.7.4
io.fabric8:kubernetes-client
Maven
5.9.0 up to 5.10.2, plus listed versions
5.10.05.10.1
5.10.2
io.fabric8:kubernetes-client
Maven
5.11.0 up to 5.11.2, plus listed versions
5.11.1
5.11.2
jenkins-2-plugins
Red Hat:ocp_tools:4.13::el8
From an advisory covering 16 CVEs
before 0:4.13.1684911916-1.el8
0:4.13.1684911916-1.el8
jenkins
Red Hat:ocp_tools:4.13::el8
From an advisory covering 16 CVEs
before 0:2.387.3.1684911776-3.el8
0:2.387.3.1684911776-3.el8

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubshoucheng3/fabric8io__kubernetes-client_CVE-2021-4178_5-0-22025-08-17

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-4178 is a medium vulnerability (CVSS 6.7) in Redhat A-mq Streams, published July 15, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in io.fabric8:kubernetes-client 5.0.3.

References

Show 78 moreShow less
MoveEnter Open